RELEASE: Ultraschall 3.0.2


#81

@Mespotine Kannst du einmal diese Version testen:

https://github.com/Studio-Link-v2/backend/releases/download/v17.02.2-beta/studio-link-plugin-onair-windows64.zip

Einfach die .dll austauschen unter C:\Program Files\Steinberg\VstPlugins


#82

Ok super Tipp. Ich teste das heute Abend - gehe davon aus dass es super klappen wird.


#83

Leider tritt der Fehler immer noch auf. Ich hab mal nen Video gemacht, in dem ich versucht habe den Fehler zu provozieren, konnte aber nur reproduzieren, dass der Absturz immer noch passiert:
http://www.phantastika.org/stuf/Mespotine-Studiolink-Betatest-14-3-2017.mp4
Die Projektdatei aus dem Video kannste hier runterladen: http://www.phantastika.org/stuf/!!US.zip
Hatte vergessen die Aufnahme des Mauszeigers einzustellen, aber das Anklicken von Bedienelementen sollte trotzdem gut genug zu sehen sein.
Gibts vielleicht ne Möglichkeit irgendwelche Daten mitzuloggen, aus denen Du schlau werden könntest? Variablennamen oder irgendwelche Übergabeparameter oder irgendwas?

@rstockm
Ich hab mir gestern mein System neu aufgesetzt, alle Windows7-Updates, aktuellstes Reaper und US3.0.2 und nun bekomme ich beim Start ne Fehlermeldung, dass er Funktionen in ner bestimmten dll nicht mehr findet und danach, dass US3 nicht korrekt installiert ist(ist auch im Video oben zu sehn).

Vor dem Neuaufsetzen hatte ich das Problem nicht, also geh ich davon aus,dass ich irgendetwas nicht installiert habe, was Ultraschall braucht. Nur weiß ich nicht, was das sein könnte…
Hab auch schon aus nem Backup die entsprechenden dll r√ľberkopiert, aber das hat nicht so wirklich funktioniert‚Ķ
Hab noch nicht getestet, ob der Fehler auch mit US2.2.2 oder US3.0.1 passiert…

Achso, am Ende des Video ist noch was zu sehn, da wei√ü ich nicht, obs ein Bug ist oder nicht. Da konnte ich, w√§hrend ‚Äúder laufenden Sendung‚ÄĚ ein neues Projekt anlegen, ohne dass der Senden-Button ausgeschaltet wird(evtl das Senden auch?). Soll das so?


#84

@rstockm @StudioLink

Hab im Internet gesucht und gefunden, dass es ein Update gibt, welches noch nicht bei mir installiert war: https://support.microsoft.com/de-de/help/2999226/update-for-universal-c-runtime-in-windows

Hab US3.0.2 nochmal deinstalliert und neu installiert und seither funzt US wunderbar.
Kurioserweise scheint das auch die Absturzprobleme von Studiolink(in der US3.0.2 Version) gelöst zu haben, konnte zumindest keinen Absturz mehr herauskitzeln. Ich versuchs nochmal heut Abend intensiver…

Vielleicht machts Sinn nen Hinweis auf das Windows-Update in ne US-FAQ zu packen?


#85

Hallo,

konnte es leider erst gerade eben testen. ESC l√∂scht den Inpoint nicht. Vielleicht k√∂nnte man das ja mitaufnehmen f√ľr die n√§chste Release.

Ansonsten schneidet es sich wirklich super gut, sehr viel schneller und angenehmer. Danke!


#86

Doch, löscht es. Wenn man jedoch einen Outpoint setzt, ohne dass es einen Inpoint gibt, so nimmt er den Projektstart als Inpoint. Irgendwas braucht er halt als Inpoint…


#87

Stimmt, da hast du mich beim Käse schreiben erwischt.

Dann wird das nix mit zuerst outpoint setzen


#88

…was spricht dagegen, dass du dir ein Makro baust, dass gleichzeitig Inpoint und Outpoint setzt, und das dann auf eine neue Taste legst?


#89

gar nichts :slight_smile: ist schon erledigt und dank der Vorlage auch bei meinen Shortcuts eingetragen.

Ultraschall Keyboard Layout Custom.pdf (98,8 KB)


#90

Was ist denn mit der Schrift los - im Original auch so?


#91

Das ginge nat√ľrlich, aber dabei muss man zu viel denken. Was ich mir w√ľnschen w√ľrde: Wenn man einen Outpoint setzt und kein Inpoint gesetzt ist, dann Inpoint = Outpoint.

Edit:
Hier was behelfsmäßiges: Set inpoint = outpoint if inpoint = 0.lua
reaper.Main_OnCommand(40626, 0) -- set outpoint inpoint, outpoint = reaper.GetSet_LoopTimeRange2(0, false, false, 0, 0, false) -- get in-point and out-point reaper.SetEditCurPos2(0, outpoint, true, false) -- move edit cursor to out-point if inpoint == 0 then reaper.Main_OnCommand(40625, 0) -- set in-point = out-point end reaper.UpdateArrange()


#92

ich denke das hat damit zu tun, dass manche Objekte - wie auf der Taste M - mit der Schriftart Ultraschall ‚Äúgeschrieben‚ÄĚ werden ‚Ķ und die habe ich nicht installiert.

Und deswegen habe ich auch erst das R und den Banner hingemacht ‚Ķ weil das Logo √ľber den Shortcuts scheint eine 1 in der Schriftart zu sein.


#93

Bei meinen ‚ÄúAvid Mediacomposer like‚ÄĚ Makros findet ihr auch ein paar f√ľr das Setzten und Entfernen von In- und Outpoints. Es wird auch ein Out angezeigt, wenn es keinen IN-Punkt gibt, oder er davor liegt: https://github.com/fernsehmuell/reaper_scripts oder auch √ľber den reapack Paketmanager. https://reapack.com/repos


#94

@StudioLink
Hab nochmal genau getestet und leider trat der Absturzfehler wieder auf. Diesmal dauerte es aber etwas, bis er auftrat,dann jedoch häufig.
Am Meisten konnte ich ihn reproduzieren, wenn ich in den Preferences unter dem Punkt VST Plugins den Clear/Rescan VST Button geklickt habe, das f√ľhrte fast immer zum Absturz, als w√ľrde es beim Laden/Initialisieren des Plugins ein Problem geben.
Hab das Ganze auch mal ausprobiert indem ich nur das Studiolink-Plugin aktiviert hatte, also ohne die onair-dll und dann st√ľrzte Reaper auch ab, auch fast immer beim Dr√ľcken des Clear/Rescan-Buttons.


#95

Die Ultraschall-Schrift gibt es zum selber installieren hier:

bzw direkt
https://github.com/Ultraschall/US-Font-Icons/tree/master/fonts


#96

Also in der Powerpoint Datei ist was durcheinander ‚Ķ die Symbole passen nicht immer zu den shortcuts und z. B. wird auch ein ‚Äúh‚ÄĚ im Ultraschall Font verwendet - was ja keinen Sinn macht.

Ist jetzt aber nicht wirklich tragisch


#97

Spoiler alert:


#98

Hallo @heikopanjas, @rstockm und alle anderen, die an der neuen Version mitgearbeitet haben. Vielen Dank f√ľr eure M√ľhe! Ich hatte noch nicht viel Zeit zum Testen, aber alleine die verbesserte Funktion, den Lautst√§rkeverlauf einer Spur anzupassen, gef√§llt mir sehr.

Zwei Anmerkungen habe ich:

  1. In der aktuellen Freakshow sagtest du, Ralf, dass es einen (neuen?) Startscreen gibt. Bei mir erscheint da aber nichts.

  2. Wenn ich Reaper starte, öffnet sich ja automatisch ein leeres, neues Projekt. Wenn ich dann direkt ein Template auswähle kommt trotzdem der Dialog, ob ich das (unveränderte) leere Projekt speichern möchte. Vorher wurde das Speichern erst abgefragt, wenn ich was an dem Projekt verändert habe, wenn ich das richtig erinnere. Ist nur eine Kleinigkeit, aber könnte etwas nervig werden.

Danke nochmal f√ľr eure Bem√ľhungen und macht weiter so :slight_smile:


#99

Zu 1.: Ich glaube, der neue ‚ÄúStartscreen‚ÄĚ ist das Fenster mit den Links zu Tutorials, Sendegate etc. Taucht bei jedem Start auf, bis man das H√§kchen raus nimmt‚Ķ
Zu 2.: Das irritiert mich auch - nicht mehr so sehr wie am Anfang, aber trotzdem muss ich jedes Mal innehalten, weil ich Angst habe, versehentlich was nicht zu speichern… :upside_down_face:


#100

Ah, das w√ľrde Sinn machen. Das erschien bei mir auch. Mich wundert es nur, dass weder der Reaper-, noch der Ultraschall-Splashscreen angezeigt wird. Ist im Zweifel aber auch nicht wichtig.