Umgang mit Multitrack-WAV

Hallo zusammen,

der Rodecaster Pro zeichnet intern in einem Multitrack-WAV Format auf. Man kann die Datei zwar in Reaper importieren und dann den Track in einzelne Spuren splitten, das ist jedoch etwas umständlich und löst das Problem nicht, dass eine einzelne Aufnahme durch das unkomprimierte Format auf der Platte einiges ein Speicherplatz verschwendet.

Was wäre die sinnvolle Art mit solchen Dateien umzugehen? Multitrack in einzelne Dateien splitten und dann alle in FLAC konvertieren? Oder gibt es irgendeine Funktion in Reaper/Ultraschall, die das vereinfacht?

1 Like

Das ist ja mit Reaper schnell gemacht:

  1. Rechtsklick auf Item > Item processing > Explode multichannel audio...
  2. File > Render... > Source: Stems, Output Format: FLAC

Beim Speichern des Projekts kannst du auswählen, dass die Dateien in FLAC konvertiert werden sollen:
21

Wenn es dir nur um das Konvertieren geht, wäre Sox eine Alternative:
sox input.wav output.flac
wirft ein Multichannel-FLAC aus.

Wenn du lieber Einzeldateien hättest, geht das mit

sox input.wav output_1.flac remix 1
sox input.wav output_2.flac remix 2
sox input.wav output_3.flac remix 3
...

Ein Skript, um Dateien mit beliebig vielen Channels in Einzeldateien aufzutrennen, steht in der Beschreibung des Remix-Effekts.

#!/bin/sh
chans=`soxi −c "$1"`
while [ $chans −ge 1 ]; do
   chans0=`printf %02i $chans`   # 2 digits hence up to 99 chans
   out=`echo "$1"|sed "s/\(.*\)\.\(.*\)/\1−$chans0.\2/"`
   sox "$1" "$out" remix $chans
   chans=`expr $chans − 1`
done

Wenn du darin die fünfte Zeile durch folgendes ersetzt

   out=`echo "$1"|sed "s/\(.*\)\.\(.*\)/\1−$chans0.flac/"`

bekommst du beim Ausführen von meinskript.sh input.wav FLAC-Dateien.

Alles ungetestet und ohne Gewähr. :slight_smile:

5 Like

Super Tipps, ich probiere die mal aus :slight_smile: Vielen Dank!

1 Like

Ich habe das Skript noch etwas angepasst, um nur die Kanäle aus der Rodecaster-WAV zu extrahieren, die ich wirklich brauche.

#!/bin/bash

function convert() {  
  filename=$1
  
  suff=$2
  
  channel=$3
  
  filename_without_ext=`echo "${filename}"|sed "s/\(.*\)\.\(.*\)/\1/"`
  
  mkdir -p $filename_without_ext
  
  channel_frmt=`printf "%02d" $channel`
  
  new_filename="${filename_without_ext}/${filename_without_ext}-${channel_frmt}−$suff.flac"
  
  echo "Extracting channel ${channel} to ${new_filename}..."
  
  sox $filename $new_filename remix $channel
}

convert $1 "Left" 1
#convert $1 "Right" 2
convert $1 "Mic-1" 3
#convert $1 "Mic-2" 4
#convert $1 "Mic-3" 5
#convert $1 "Mic-4" 6
convert $1 "USB-Left" 7
#convert $1 "USB-Right" 8
#convert $1 "TRRS-Left" 9
#convert $1 "TRRS-Right" 10
#convert $1 "Bluetooth-Left" 11
#convert $1 "Bluetooth-Right" 12
#convert $1 "Sounds-Left" 13
#convert $1 "Sounds-Right" 14
2 Like

Hallo zusammen,

Habe das Rodecastrer ausgeliehn bekommen von einem Kollegen und mache grad paar Tests. Die wie hier beschriebene Aufsplitung der Aufnahme im Gerät hat bei mir funktioniert, danke für die Erklärung.
Jetzt stellt sich mir jedoch noch die Frage, wie ich direkt im DAW über Rodecaster die Spuren einzeln bekomme. Habe bei Rode diese Anleitung für Reaper gefunden. Da ich jedoch durch Ultraschall das alles etwas anders aussieht, wollte ich fragen, wie ich das am einfachsten machen kann.

Noch eine zusätzliche Info und dazugehörige Frage. Ich nehme stets mit einem Kollegen auf, der per Studiolink zugeschaltet ist. Wenn ich die Aufnahme intern auf dem Gerät speichere, kann ich ihn über die USB-Spur aufnehmen. Ist das in Sachen Qualität okay, oder gibt es da andere Wege? Wenn ich die Aufnahme in Reaper mit dem Multitrack hinbekomme, würde sich das mehr oder weniger erledigen, aber wäre einfach gut zu wissen.

Danke für eure Hilfe,
Jeff

Der Rodecaster muss in den Multi Track Modus geschalten werden.
Danach hast du zwei Interfaces zur Auswahl

  • eines für die Inputs
  • eines für den Rückkanal an das Rodecaster Pro

Siehe im Rodecaster Thema:

Step 3 deiner Anleitung für Reaper (basis von Ultraschall) beschreibt genau diese Einstellung des Audio Interfaces:

STEP 3

  • In REAPER Preferences, go to Audio / Device and ensure the Input Device is RODECaster Pro Multichannel.
  • Tick “Request block size” and enter 1024.
  • Tick “Allow projects to override device sample rate”.
  • Tick “Allow use of different input and output devices” and change
  • Output Device to RODECaster Pro Stereo.
  • Click OK.
1 Like

Hallo Christian,

Das habe ich bereits so eingestellt. Dennoch erhalte ich lediglich den Stereo-Mix. Den kann ich auch nicht aufsplitten. In der Anleitung wird erklärt, dass man jeweils Spuren anlegen soll. Kann aufgrund des Layouts von Ultraschall dann diesen jedoch nicht den jeweiligen Kanal (von den 12 des Geräts) zuweisen. Oder übersehe ich etwas?

BG,

Jeff

Edit: hab gefunden, wo ich den Spuren den Kanal zuweise. Hatte übersehen, dass man das auch unten am Pegel einstellen kann. Dass man das händisch machen muss ist zwar etwas nervig, aber ich denke mal man kann das einmal gemacht, auch als Tamplate einstellen. Mal schauen ob ich das hinbekomme. Jedenfalls schonmal Danke Christian. :slight_smile:

Am besten ist du legst dir je nach Bedürfnis ein Projekttemplate an und öffnest dieses danach.
Dann hast du alle Einstellungen etc. so wie du sie dir gewohnt bist wieder bei jeder Episode parat.
Es empfielt sich z.B. ein Template für rein lokale Aufnahme, dann eines mit Studiolink (falls verwendet) oder spezielle Routings mit Audio-Devices, wenn du Skype oder ähnliches mal in Ultraschall brauchst.

Siehs als eine Art Werkbank an, bei der du dann immer die passende Schublade für jede Aufgabe parat hast. :wink:

Es kommen ja doch ein paar Einstellungen zusammen, die du nicht jedes Mal aufs neue machen magst.

1 Like