Studio Link - BugBoard


#144

Lieder nimmt die Live-Stream Maske keine Twitter Namen die ein ‘_’ enthalten …


#145

Slug has already taken - Streamen von einem Podcast mit 2 Geräten?

Ich habe das Livestreamen mit einem Notebook eingerichtet und getestet. Mit dem Gerät senden wir ab und an von unterwegs.

Das Hauptgerät (iMac) meckert nun natürlich den Slug an:

Habe ich hier einen Denkfehler oder wie könnte man das lösen?


#146

Das geht so nicht. Du musst den selben Account verwenden sonst bist du zwei mal in der Datenbank von studiolink.

Das geht aktuell nur mit mehreren Rechnern wenn du die Zugangsdaten für studiolink manuell auf den iMac kopierst. Diese liegen in einer Datei. Wo die liegt wurde hier im
Sendegate schonmal beschrieben irgendwo.


#147

Klingt sinnig.

Edit:
Ah, hier oben im Thread steht es ja: Studio Link - BugBoard

Hat geklappt, diese Dateien vom MacBook auf den iMac kopiert.
Läuft.

:+1: Danke, @funkenstrahlen


#148

Der Unterstrich ist nicht das Problem, sondern das ‘@’ am Anfang.


#149

Danke für den Hinweis!


#150

Hi,

mir ist in einer Live-Sendung nun Reaper komplett weggerüsselt, danach hat es den Audiotreiber so durcheinander gebracht, dass es extreme Störungen gab, sodass ich neustarten musste.

Kurz zum Setting:
Windows 10 x64
image

Software-Setting war nicht simpel: Lokales Interface, drei Studio Link-Spuren, ein Soundboard, ein externes mp3-Player-Plugin, Livestream über Studio Link On Air. Gesprächspartner war ein StudioLink-Teilnehmer, die verbleibenden zwei Studio Link-Spuren standen für Anrufer zur Verfügung.
Ich konnte in der Sendung bereits erfolgreich ein klassisches Telefonat via SIP/StudioLink führen (Anbindung via Fritzbox). Angenommen, telefoniert, aufgelegt, funktionierte astrein.
Als ich einen anderen StudioLink-Teilnehmer mit in die Sendung holen wollte (also quasi selbes Setting wie beim Analog-Telefonat, nur nun Studio Link), ist Reaper wortlos abgestürzt - und so der ganze Stream kaputt gegangen.

Hier der Eventlog-Auszug:

Name der fehlerhaften Anwendung: reaper.exe, Version: 5.7.0.0, Zeitstempel: 0x5a307ded
Name des fehlerhaften Moduls: studio-link.dll, Version: 17.3.1.0, Zeitstempel: 0x58de7bc8
Ausnahmecode: 0xc0000005
Fehleroffset: 0x000000000001034f
ID des fehlerhaften Prozesses: 0xb6c
Startzeit der fehlerhaften Anwendung: 0x01d392b4be19ded5
Pfad der fehlerhaften Anwendung: C:\Program Files\REAPER (x64)\reaper.exe
Pfad des fehlerhaften Moduls: C:\Program Files\Steinberg\VstPlugins\studio-link.dll
Berichtskennung: 26272a6e-708f-47e2-93a1-a7d8369e5222
Vollständiger Name des fehlerhaften Pakets: 
Anwendungs-ID, die relativ zum fehlerhaften Paket ist: 

Eine Ahnung, woran es liegen könnte?


#151

Lässt sich das reproduzieren? Ich teste das nachher einmal.


#152

LV2-Plugin wie auch Standalone laufen nicht unter aktuellem Debian
Linux XXXX 4.9.0-5-amd64 #1 SMP Debian 4.9.65-3+deb9u2 (2018-01-04) x86_64 GNU/Linux

denn beide verlangen

  • libssl.so.1.0.0 (Debian hat 1.0.2)
  • libcrypto.so.1.0.0 (Debian hat auch hier die 1.0.2)

Wenn man einfach Symlinks libssl.so.1.0.0 -> libssl.so.1.0.2 und selbes für libcrypto frickelt, dann meckert ein Aufruf zusätzlich das Fehlen der OPENSSL_1.0.1 an:

./studio-link-standalone: /usr/lib/x86_64-linux-gnu/libssl.so.1.0.0: version `OPENSSL_1.0.1' not found (required by ./studio-link-standalone)
./studio-link-standalone: /usr/lib/x86_64-linux-gnu/libssl.so.1.0.0: version `OPENSSL_1.0.0' not found (required by ./studio-link-standalone)

Gibt es irgendwo eine Debian-kompatible Version?
Oder kann man das einfach aus https://github.com/Studio-Link-v2/backend selber compilieren (oder muss man was komplexeres machen)?


#153

Du kannst mal folgende Standalone Version probieren: https://github.com/Studio-Link-v2/backend/releases/download/v18.02.0-alpha2/studio-link-standalone-linux.zip


#154

Ok, startet jetzt erst mal sauber auf aktuellem Debian-stable.

Ich kann die Testaccounts anrufen & anhören (der Default-Test music@studio-link.de gibt’s nicht 404, dafür kann man die freakshow[123]@studio-link.de anrufen).

Leider bekomme ich kein Signal vom Laptop-Mikro (was unter anderen Audio-Anwendungen geht).

Auch scheine ich auf das Device hw0 festgenagelt zu sein. Kann ich das irgendwo auf hw1 (das USB-DEvice) ändern? Da die Baresip-Konfig .studio-link/config anscheinend jedes Mal von studio-link-standalone überbügelt wird, nutzt ein 'rumkonfigurieren dort nichts. Kann man da etwas mit der -u Option ändern? Wenn ja: wie ist da die Syntax?

Danke!


#155

Teste mal die frische Alpha Version:
https://github.com/Studio-Link-v2/backend/releases/download/v18.02.0-alpha-461.794f1ea/studio-link-standalone-linux.zip

Da habe ich gestern unter “Interface” die Auswahl vom Audio Interface integriert. Am besten einmal mit dem "echo@studio-link.de" Account testen.

Richtig der existiert noch nicht (kommt die Tage erst).


#156

Moin!

Die Erkennung hakt leider noch - beim Aufruf:

...
dfe10fd1@studio-link.de: Using medianat `turn'
*0: hw:HDA Intel PCH,0: 48000
 1: hw:HDA Intel PCH,3: 48000

RtApiAlsa::getDeviceInfo: pcm device (hw:1,0) data format not supported by RtAudio.

 2: : 48000
 3: default: 48000
Populated 3 audio codecs
Populated 3 audio filters
Populated 0 video codecs
Populated 0 video filters
baresip is ready.
...

Mein Audio-Setup:

root@keket:~# aplay -l
**** Liste der Hardware-Geräte (PLAYBACK) ****
Karte 0: PCH [HDA Intel PCH], Gerät 0: ALC269VC Analog [ALC269VC Analog]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: PCH [HDA Intel PCH], Gerät 3: HDMI 0 [HDMI 0]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 1: Blackjack [Onyx Blackjack], Gerät 0: USB Audio [USB Audio]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0

Dafür die “gute” Nachricht: ich habe festgestellt, dass mein Laptop-Mikro kaputt ist - daher vmtl. auch das nichtfunktionale Gespräch gegen Echo: wo kein Input da kein Output. Ich bau gleich mal meinen Laptop um und schalte die eingebaute Soundkarte ab. Dann sollte die USB hw0,0 sein…


#157

Kannst du einmal folgendes ausführen:

$ arecord --dump-hw-params -D "hw:1,0"
und
$ aplay --dump-hw-params -D "hw:1,0"

Ich vermute das “S16_LE” nicht unterstützt wird vom Interface. Falls das der Fall ist müsste ich noch eine passende Format Konvertierung einbauen/aktivieren. Ein Workaround bis dahin könnte ein virtuelles Interface über die ~/.asoundrc sein.


#158

Gut geraten! tatsächlisch scheint das Mackie nur 24bit zu mögen (und aplay hängt…).

volker@keket:~$ arecord --dump-hw-params -D "hw:1,0"
Aufnahme: WAVE 'stdin' : Unsigned 8 bit, Rate: 8000 Hz, mono
HW Params of device "hw:1,0":
--------------------
ACCESS:  MMAP_INTERLEAVED RW_INTERLEAVED
FORMAT:  S24_3LE
SUBFORMAT:  STD
SAMPLE_BITS: 24
FRAME_BITS: 48
CHANNELS: 2
RATE: [44100 48000]
PERIOD_TIME: [1000 1981429)
PERIOD_SIZE: [45 87381]
PERIOD_BYTES: [270 524286]
PERIODS: [2 1024]
BUFFER_TIME: [1875 3962858)
BUFFER_SIZE: [90 174762]
BUFFER_BYTES: [540 1048572]
TICK_TIME: ALL
--------------------
arecord: set_params:1299: Sample-Format nicht unterstützt
Available formats:
- S24_3LE

#159

Ok, mit einer primitiven USB-Soundkarte (Behringer AUC-202) funktioniert’s - auch wenn die Latenz von echo@studio-link.de mit ~500ms echt mörderisch ist.

Das Zoom H6 geht auch - aber nur im Mixdown-Modus (mit ähnlicher Latenz), nicht aber im Multitrack-Mode (im Multitrack hat das auch nur den S24_3LE).


#160

Hallo -

Ich stecke fest: wenn ich über Ultraschall einen StudioLink Call starten möchte, komme ich nicht bei meinen Gesprächspartnern an. Gleiches gilt für den echo Call oder auch freakshow1. Der Status des Call ist für ein paar Sekunden “Outgoing”, nach ein paar Sekunden erscheint die Meldung call closed: operation timed out.

Woran kann das liegen? Für jeden Hinweis besten Dank im Voraus!


41


#161

Hi, es sieht danach aus als wenn etwas die SIP bzw. RTP (UDP) Verbindung blockiert. Ist an deinem Netzwerk Setup irgendwas besonders eingeschränkt? Sehr restriktive Firewall oder ähnliches?


#162

Ok, das hat schon geholfen! Ich war mit dem Rechner bei den letzten Versuchen aus irgendeinem Grund im Gastnetzwerk der Fritzbox und kam nach Deinem Kommentar auf die Idee das zu ändern… Läuft nun wieder einwandfrei, wie es soll. Nächster Schritt ist dann wohl, die Einstellungen im Gastnetzwerk anzupassen und ein LAN-Kabel in der richtigen Länge zu besorgen… Besten Dank für den Schubser!


#163

Ich hab auf meinem Windows Laptop (Win10 Home, 64bit, aktuelle Version) leider immer noch das Problem dass StudioLink nicht will. Gibt es irgendwelche ominösen Firewall/Security Einstellungen in Windows? Am Wlan kann es nicht liegen, mit meinem Mac im selben Netz funktioniert alles und mit meinem vorherigen Win Laptop gabs auch keine Probleme :frowning:

2018-09-02%20(1)