Steuerung des Ultraschall-Soundboards mit einem iPad via OSC

Damit hier keine Langeweile aufkommt, gleich mal Folge 18 des Ultraschall-Screencasts:

Erstmals gibt es einen Gast-Presentator, nämlich Breitschwert-Besitzer @danlin himself!

Diese Tools braucht Ihr:

http://hexler.net/software/touchosc
http://hexler.net/docs/touchosc-editor
Und sein Template:

Habt Spaß!

Oh - und wir haben endlich mal einen Twitter-Account gebaut:
https://twitter.com/ultraschall_fm

4 Like

Ja ist denn schon wieder Weihnachten? Great Job, @danlin!

1 Like

Hab das letzten Freitag bei einem Freund installieren wollen und es hat auch fast alles geklappt nur konnte ich auf TouchOSC keine Aktionen auf dem Soundboard ausführen. Die Einstellungen passten alle und die Namen der Sounds standen auch da aber es reagierte auf keins der Tasten oder Lautstärkeregler.
Könnte es vielleicht an OSX Mavericks 10.9.5 liegen?

1 Like

Kannst du verifizieren das beide Geräte grundsäzlich miteinander reden? ping $iPad ist zwar nicht der Weisheit letzter Schluss aber als Basis schon mal vernünftig.
Geschlossene/firewalled/blocked ports oder so banale Sachen wie wifi isolation erweisen sich manchmal als Teufelswerk.

open ports checken

oder z.B. netstat -a (Win/Mac) sieht man auch gleich ob und wer dran rumrüsselt.

Wobei dies gegen missgeglückte Kommunikation spricht.

1 Like

Interessant. Ich habe unter Mavericks das gleiche Problem.

2 Like

Ich darf zurückmelden, dass ich sowohl unter Mavericks als auch unter Yosemite das Problem habe, dass die einzelnen Tracks allen Funktionen ferngesteuert folgen, ich auf dem iPad jedoch keine Titel oder sonstige Informationen darüber angezeigt bekomme.

Hat jemand die selben Erfahrung?

1 Like

Hast du in den Einstellungen des Soundboards sowohl “Send” als auch “Receive” aktiviert?

1 Like

Ja, habe ich. Wie gesagt: Soundboard reagiert auf alle Kommandos via iPad. Nur: Ich sehe leider nicht, welcher Sound auf welcher Position ist. Ist somit eher try and error.

1 Like

Unter Yosemite funktioniert bei mir alles. Damit übrigens die Sounds auf dem iPad angezeigt werden hilft es oft das Preset im Soundboard in Reaper nochmal auszuwählen.

1 Like

Danke für den Tipp. Hilft in meinem Fall leider nicht weiter. Auf dem iPad wird nichts angezeigt.

1 Like

Bekommt man das Template eigentlich auch irgendwie ohne den TouchOSC-Editor auf’s iPad? Ich möchte ungerne für den einmaligen Sync-Vorgang Java installieren.

1 Like

ja mit zum Beispiel “iExplorer”. Gerät anschließen, App suchen und dann in den Order “Documents” die Template Datei reinziehen, da sollten auch schon Templates drin sein. Die Demo Version von iExplorer reicht.

3 Like

Perfekt wärs noch, über touchOSC Kapitelmarken setzen zu können… Zurücklehnen, iPad am Schoß und ohne klickgeräusche aufnehmen … :wink:

1 Like

einfach zärtlich auf die WiiMote drücken, dann gibts auch keine Geräusche :stuck_out_tongue:

1 Like

Für iPad plus WiiMote sind meine Patschehändchen zu klein… :wink:

1 Like

Zwei Punkte sind @danlin und mir eben beim Testen noch aufgefallen:

  1. wenn es mit dem Rückkanal iPad->Reaper Probleme gibt mal als HOST im TouchOSC die IP des Rechners nehmen statt den Namen
  2. Generell sollte dieser Schalter - gerade für Tests - deaktiviert werden:

2 Like

Danke Ralf. Hatte das gleiche Problem, dass zwar die Titel angezeigt aber nicht ferngesteuert werden konnten.

IP des Rechners eintragen hat geholfen.

Funktioniert TouchOSC bei euch noch? Auf meinem iPad mini (1) mit iOS 8.2 funktioniert es nicht mehr.

Was genau meint läuft nicht mehr? Unter 8.3 startet es zumindest - Verbindung etc. Muss ich noch testen

Das funktioniert ja schonmal ziemlich gut und ich haben angefangen, mir aus bestehendem was eigenes zusammenzubetteln.

Ich hab da rechts eine große Freifläche und das hat auch sein Ziel.
Mir ist aufgefallen, dass es bisher 2 Hauptsächliche Layouts gibt, zum einen ein Mutesetup und zum anderen das Soundboard. jetzt Meine Frage: Kann ich ein Soundboardsetup in diesem Layout unterbringen? Mir ist schon aufgefallen, dass der Verbindungspunkt für den Mute über die actionlist geht, das Soundboard wird aber in den Einstellungen da verbunden und von dem taucht auch nichts in der Actionlist auf. Gibt es da schon einen workaround, ist das umsetzbar was ich mir so vorstelle?
Edit
Ich habe gerade mal versucht, an beiden Stellen als Eingang Port 8050 zu verwenden, das funktioniert aber nicht