Podcast-Episoden-Seiten/Beiträge inhaltlich doppelt?


#1

Hallo,

ich helfe gerade bei einer Installation aus, die von einem anderen Server migriert und dann mit einem anderen Theme ausgestattet wurde.

Nun werden bei den Beiträgen, die für Podcast-Episoden erzeugt werden, die Inhalte doppelt dargestellt, also zwei Mal der Webplayer, zwei Mal die Liste der Contributors.

Ich fühlte mich an diesen Beitrag erinnert, aber das dort genannte Plugin ist nicht installiert.

Plugins habe ich ansonsten soweit auch sonst ausgeschlossen. An den Theme-Einstellungen mögen wir wegen einiger Anpassungen nur begründet Änderungen vornehmen.

Hat jemand eine Idee für einen guten Ansatz zur Fehlersuche? Danke!

Website                    http://____.____
PHP Version                7.2.16-he.0
WordPress Version          5.1.1
WordPress Theme            EntourageWP v2.0
Active Plugins             
           - Redux Framework v3.6.15
           - Antispam Bee v2.9.1
           - WR Custom Post Type v1.0
           - EU Cookie Law v3.0.5
           - WPBakery Page Builder v5.7
           - Maintenance v3.6.1
           - Podlove Podcast Publisher v2.7.24
           - Podlove Subscribe Button v1.3.6
           - Redux Developer Mode Disabler v1.0.1
           - Statify v1.6.3
           - UpdraftPlus - Backup/Restore v1.16.12
           - Wordfence Security v7.2.5
           - WordPress Importer v0.6.4
           - WP Maintenance Mode v2.2.3
           - WP User Avatar v2.2.4
WordPress Database Charset utf8
WordPress Database Collate 
Publisher Version          2.7.24
Web Player Version         player_v4
Twig Version               1.38.3
open_basedir               ok
curl Version               7.38.0
iconv                      available
simplexml                  ok
max_execution_time         30
upload_max_filesize        32M
memory_limit               256M
disable_classes            
disable_functions          syslog
permalinks                 ok (/%postname%/)
podlove_permalinks         ok
podcast_settings           ok
web_player                 ok
podlove_cache              on
assets                     
  - mp3    audio/mpeg       http://____.____/feed/_____/
cron                       ok

0 errors
0 notices
Nice, Everything looks fine!

#2

Ich tippe auf ein Problem beim Podlove-Template. Man kann an zwei Stellen festlegen, ob und wenn ja welches Template automatisch eingefügt werden soll. Das verursacht häufig so ein Problem.


#3

Danke, aber das war es leider nicht. Das automatische Einfügen ist nur bei den Templates aktiviert und dort auch nur einmal.


#4

Auch wenn es in meinem Fall ein anderes Cookie-Plugin war. Mach das Cookie Notice Plugin mal aus und dann einmal den Cache leeren. Könnte sein, dass das hier auch der Verursacher ist.


#5

Ok. Danke. Abgeschaltet war’s, aber für die Löschung des Caches kann ich meine Hand nicht ins Feuer legen.

Das wird getestet. Danke!


#6

Update: Daran lag es auch nicht. Cache mehrfach gelöscht, auch in Kombination mit der Reparatur-Funktion vom Podlove Publisher. Aber danke!


#7

In podlove->templates das gleiche Template am Anfang und am Ende ausgewählt?

Oder

Ausversehen den Template Code doppelt eingefügt?

… Ein Link mag helfen.


#8

Danke für Deine Antwort. Das Template ist nur ein einziges Mal zum Einfügen ausgewählt.

Manueller Templatecode kommt gar nicht zum Einsatz. Eine URL würde nicht weiterhelfen, die Seite ist noch nicht ohne Login zugänglich (und auch nicht meine).


#9

Ein Template wurde ausgewählt, aber gar keins wird benutzt?? Das erschließt sich mir nicht ganz.

Wurden ggf. früher Player oder Templates per shortcode in den Beiträgen eingefügt? Setze mal beide Template Felder auf “nichts”. Sind dann beide Player weg, liegt es am Template.bleibt einer, kommt der aus dem Post.


#10

Es ist automatisches Einfügen ausgewählt. Schalte ich das ab, erscheint kein Player mehr. Es werden keine Shortcodes eingesetzt.

Also: Schalte ich manuelles Einfügen nur an einer Stelle ein, erscheinen zwei Player. Schalte ich dieses manuelle Einfügen aus, kommt gar keiner mehr.


#11

Dann muss es ja an dem Template liegen, das Du einfügen lässt.


#12

Leider nicht, es ist das Standardtemplate. Aber irgendetwas lässt es zwei Mal einfügen. Ich gehe inzwischen vom Theme aus.


#13

Bist du sicher, dass niemand am Template gefrickelt hat und da nicht irgendwie ein zweites episode.player reingefallen ist? Magst Du vielleicht mal Dein Template posten?

Wenn beim Abschalten des automatischen Einfügens gar kein Player mehr angezeigt wird, dann kann es doch eigentlich eher nicht vom Theme kommen, wie @schaarsen ja auch schon vermutete.


#14

Bist du sicher, dass niemand am Template gefrickelt hat und da nicht irgendwie ein zweites episode.player reingefallen ist?

Ja. Hier das Template:

{% if not is_feed() %}
{# display web player for episode #}
{{ episode.player }}

{# display download menu for episode #}

[podlove-episode-contributor-list]

{% endif %}

Zudem wird ja auch die Liste der Contributors doppelt angezeigt. Füge ich im Template Text hinzu, erscheint er auch doppelt.

dann kann es doch eigentlich eher nicht vom Theme kommen

Das weiß ich schlicht nicht. Ich kenne den Mechanismus nicht genug, um auszuschließen, dass z.B. die Funktion zum Einfügen des Codes doppelt getriggert werden kann oder so etwas.