2 Webplayer in den Episoden durch Nutzung des WP-Plugins GDPR


#1

Hallo zusammen,
Habe über die Suche nichts gefunden hoffe es ist kein Doppelpost1!

Ich habe seit heute das Phänomen, das ich 2 Player in meinen Beiträgen habe.
Mein erster Gedanke nach kurzer Recherche war, das ich eventuell sowohl bei den Templates als auch bei den Webplayer-Einstellungen das automatische Einfügen an habe.
Ist aber nicht so. Shortcodes sind auch keine in den Beiträgen.
Aktuell ist nur das Template (am Template wurde nichts geändert) angestellt und es sind 2 Player da.
Ist ja vielleicht nur ne Kleinigkeit und ich sehe den Wald vor Bäumen nicht aber hat Jemand ne Idee ?

Ich bastle schon seit Stunden wegen DSGVO und mir raucht die Birne aber wüsste jetzt nicht, was ich dahingehend geändert hätte.

Achja Cache vom Browser und von Podlove wurde schon geleert.

Danke für eure Hilfe

Link zu einer Episode


#2

Hey,

es sieht so aus als ob der embedCode 2mal eingebunden wird auf die selbe ID. Das führt dazu das auch 2 Player eingebunden werden. Schau mal ob du nicht aus versehen das template zweimal einbindest.

Beste Grüße
Alex


#3

Danke für deine Antwort!!
An welchen Stellen könnte das denn erfolgen? Das Komische ist ja, das ich zumindest nicht bewusst was geändert habe.
Ich habe die ja nie manuell eingebunden.
Deswegen ja mein Verdacht mit den Einstellungen im Template und in den Webplayer-Einstellungen.

Wenn ich das einfügen über Templates ausmache ist keiner im Beitrag. Wenn ich es wieder anmache dann sind 2 da. Im Template ist aber nur ein Player vermerkt.
Gerade noch mal geprüft. Kann das Template noch an anderer Stelle nen Problem haben?

Das ist komplett unverändert :

{% if not is_feed() %}

{# display web player for episode #}
{{ episode.player }}


{# display download menu for episode #}
{% include "@core/shortcode/downloads-select.twig" %}

{% endif %}


#4

du kanst unten einstellen was am anfang und am ende eingefügt werden woll kann sein das du das dort beides malde das selbe stehen hast.

das selbe geldet auch fpr den player senbei bei podcast einstellungen


#5

Hi,
Nein beim Template nur “unten automatisch einfügen” ( oben steht auf nicht einfügen)
In den Einstellungen beim Webplayer steht auch “nicht automatisch einfügen”

Deswegen verstehe ich das ja nicht. Wie gesagt ist es ja so, wenn ich die Einstellung im Template (die untere ) “Am Ende anhängen” von “default” (Templatename) auf “nichts automatisch einfügen” ändere, habe ich keinen Player. Wenn ich das wieder auf Default ändere habe ich 2.
Wenn es woanders zB in den Webplayer Einstellungen drin stehen würde, müsste ich ja nach dem abstellen im Template noch mindestens einen haben oder ?
Echt komisch.


#6

was hast du für ein theme hast du mal ein anderes versucht ?


#7

Hi, mit Theme meine ich das Podlove Theme nicht das von Wordpress.
Dabei ist es das default Theme für das einbinden des Players welches ich nicht verändert habe.
(und welches auch ohne Probleme lief)
Siehe Code oben

Das lustige ist das ich gerade gemerkt habe, das der Effekt nur beim Podlove Webplayer 2 und 4 auftritt.
Der 3er und der Podigee wird nur einmal also korrekt angezeigt ??


#8

ich ich meinte das wordpress them das macht manchmal auch komische sachen


#9

Achso, sorry! Nutze das Hueman Theme. Haber gerade mal auf Wordpress standart geswitched und leider das gleiche Problem


#10

das ist echt komisch


#11

Ok habe den Verursacher gefunden.
Nutze seit kurzem das GDPR Plugin.
Das zeigt nen Cookie Banner und Abfrage bzw Hinweis auf den Datenschutz an.
Wenn ich das deaktiviere kommt nur ein Player.
Anscheinend blockt das dingen irgendwas. Das einfügen über die Webplayer Einstellungen funktioniert nämlich garnicht mehr.

Also zusammenfassung wenn Jemand das gleiche Problem hat.

Konflikt zwischen Podlove webplayer und GDPR Plugin

Sobald dieses Plugin aktiv ist, erfolgt über die Webplayer-Einstellungen von Podlove (automatische Einbindung) keine Einbindung mehr.
Die Einbindung über die Templates von Podlove erfolgt dafür doppelt
(Dieses Phänomen tritt allerdings nur beim Player V2 & V4 auf der 3er und Podigee laufen)

Das Problem ist hier wohl ganz klar das GDPR Plugin und nicht der Podlove Player !!!

Sofern jemand trotzdem ne Idee hat, wie man das vielleicht lösen kann, gerne her damit :smiley:

Danke an @Raumwelle und @zusatzstoff für die schnelle Unterstützung