Kritischer Fehler

Update 16.11.20: Mit dem Release 3.1.4 kann ich zumindest den Menüpunkt „Episode anlegen“ wieder aufrufen.
####################
Guten Morgen, ich wollte gerade eine neue Episode anlegen, da kommt:

Es gab einen kritischen Fehler auf deiner Website. Bitte überprüfe den Posteingang deiner Website-Administrator-E-Mail-Adresse für weitere Anweisungen.

In meinem Posteingang ist nix (ja, die Mailadresse stimmt, ich bekomme auch bspw. Infos über autom. Updates). Meine Publisher-Version ist 3.1.3

Eine ratlose Rennsandale bittet um Hilfe.

Einen schönen Sonntag
Axel

p.s. mein Podcast-Addict meint auch, dass der Feed „line 66, columnn 36: no element found“ defekt ist, dass habe ich aber noch nicht verfiziert.

Die Version hat einen ziemlichen Bug. Versuch auf die 3.1.0 zurückzugehen oder nimm die neue 3.1.4, die bald via WordPress bereitstehen sollte.

1 Like

Supi, danke. Wenn die 3.1.4 bald da ist, dann warte ich noch ein paar Tage (oder dauert es länger?)

Wurde auf Github schon veröffentlich, wann das WP Repo nachzieht weiß ich nicht.

1 Like

Inzwischen ist 3.1.12 ausgerollt und das eine Blog mit automatischen Plugin-Updates hat jetzt kein Frontend mehr, Fehler 500.

3.1.14 ist jetzt verfügbar und sollte wieder stabil sein :crossed_fingers:

Großes Entschuldigung für die fehlerhaften Releases seit gestern. Ist etwas tricky woran ich da basteln musste.

1 Like

Ich freu mich schon auf Details in der nächsten Podlovers-Epsode. :wink:

1 Like

In der LOV011 dann :wink:

2 Like

image

Nach der Installation von 3.1.14 passiert das hier; ein Rollback auf 3.1.10 hat das Problem aber jetzt dann auch nicht behoben.

Wenn ich alle Templates unter " Templates automatisch zum Inhalt hinzufügen" abwähle, dann wird das Archiv und die einzelnen Episoden wieder ohne Probleme angezeigt. Dann sind die Beiträge aber eben keine Podcasts mehr, weil der Player fehlt.

Kannst du mir bitte im PHP Error log raussuchen, was der Fehler ist? (ggf. musst du erst das Logging aktivieren https://wordpress.org/support/article/debugging-in-wordpress/)

Ein Downgrade muss auf Version 3.1.0 runter, das ist der letzte stabile Release.

1 Like

Hier die Fehlermeldung im Debug-Modus:

Fatal error: Uncaught Error: Call to undefined function twig_in_filter() in meinungsschauspieler.de/httpdocs/wp-content/plugins/podlove-podcasting-plugin-for-wordpress/vendor-prefixed/twig/twig/src/Environment.php(372) : eval()'d code:43 Stack trace: #0 meinungsschauspieler.de/httpdocs/wp-content/plugins/podlove-podcasting-plugin-for-wordpress/vendor-prefixed/twig/twig/src/Template.php(363): __TwigTemplate_17ef9c73bbe43fd30a3fb2a7f0b01245a0473ccb9b80f09d7966c3e0ee1e4b44->doDisplay() #1 meinungsschauspieler.de/httpdocs/wp-content/plugins/podlove-podcasting-plugin-for-wordpress/vendor-prefixed/twig/twig/src/Template.php(338): PodlovePublisher_Vendor\Twig\Template->displayWithErrorHandling() #2 meinungsschauspieler.de/httpdocs/wp-content/plugins/podlove-podcasting-plugin-for-wordpress/vendor-prefixed/twig/twig/src/Environment.php(372) : eval()'d code(49): PodlovePublisher_Vendor\Twig\Template->display() #3 meinungsschauspieler.de/httpdocs/wp-cont in meinungsschauspieler.de/httpdocs/wp-content/plugins/podlove-podcasting-plugin-for-wordpress/vendor-prefixed/twig/twig/src/Environment.php(372) : eval()'d code on line 43

1 Like

Hallöchen,

wir hatten das Problem, dass erst 3 Beiträge angelegt wurden statt einer, dann konnte man das nicht bearbeiten, löschen hat einen Fehler gebracht… alles in der 3.1.14.

haben jetzt die gesamte Seite zurückgespielt um 2Wochen, jetzt schaut es gut aus :smiley:

Hier mal unser Error Log von heute, Fehler traten so ab dem Update auf, das ich heute gemacht habe, also eher 3.1.14 relevant:

[Mon Nov 16 10:36:20.567193 2020] [cgi:error] [pid 1220] [client 176.94.254.32:55950] AH01215: PHP Fatal error: Uncaught Error: Call to undefined function twig_in_filter() in /var/www/sagwas/data/www/sag-was.com/wp-content/plugins/podlove-podcasting-plugin-for-wordpress/vendor-prefixed/twig/twig/src/Environment.php(372) : eval()'d code:43, referer: https://sag-was.com/geektalk/
[Mon Nov 16 10:36:20.567253 2020] [cgi:error] [pid 1220] [client 176.94.254.32:55950] AH01215: Stack trace:, referer: https://sag-was.com/geektalk/
[Mon Nov 16 10:36:20.567676 2020] [cgi:error] [pid 1220] [client 176.94.254.32:55950] AH01215: #0 /var/www/sagwas/data/www/sag-was.com/wp-content/plugins/podlove-podcasting-plugin-for-wordpress/vendor-prefixed/twig/twig/src/Template.php(363): __TwigTemplate_17ef9c73bbe43fd30a3fb2a7f0b01245a0473ccb9b80f09d7966c3e0ee1e4b44->doDisplay(Array, Array), referer: https://sag-was.com/geektalk/
[Mon Nov 16 10:36:20.568050 2020] [cgi:error] [pid 1220] [client 176.94.254.32:55950] AH01215: #1 /var/www/sagwas/data/www/sag-was.com/wp-content/plugins/podlove-podcasting-plugin-for-wordpress/vendor-prefixed/twig/twig/src/Template.php(338): PodlovePublisher_Vendor\Twig\Template->displayWithErrorHandling(Array, Array), referer: https://sag-was.com/geektalk/
[Mon Nov 16 10:36:20.568432 2020] [cgi:error] [pid 1220] [client 176.94.254.32:55950] AH01215: #2 /var/www/sagwas/data/www/sag-was.com/wp-content/plugins/podlove-podcasting-plugin-for-wordpress/vendor-prefixed/twig/twig/src/Environment.php(372) : eval()'d code(49): PodlovePublisher_Vendor\Twig\Template->display(Array), referer: https://sag-was.com/geektalk/
[Mon Nov 16 10:36:20.568860 2020] [cgi:error] [pid 1220] [client 176.94.254.32:55950] AH01215: #3 /var/www/sagwas/data/www/sag-was.com/wp-content/plugins/podlove-podcasting- in /var/www/sagwas/data/www/sag-was.com/wp-content/plugins/podlove-podcasting-plugin-for-wordpress/vendor-prefixed/twig/twig/src/Environment.php(372) : eval()'d code on line 43, referer: https://sag-was.com/geektalk/
[Mon Nov 16 10:36:21.514096 2020] [cgi:error] [pid 1227] [client 176.94.254.32:55958] AH01215: PHP Fatal error: Uncaught Error: Call to undefined function twig_in_filter() in /var/www/sagwas/data/www/sag-was.com/wp-content/plugins/podlove-podcasting-plugin-for-wordpress/vendor-prefixed/twig/twig/src/Environment.php(372) : eval()'d code:43, referer: https://sag-was.com/geektalk/202-netzneutrale-wetter-katze/
[Mon Nov 16 10:36:21.514169 2020] [cgi:error] [pid 1227] [client 176.94.254.32:55958] AH01215: Stack trace:, referer: https://sag-was.com/geektalk/202-netzneutrale-wetter-katze/
[Mon Nov 16 10:36:21.514573 2020] [cgi:error] [pid 1227] [client 176.94.254.32:55958] AH01215: #0 /var/www/sagwas/data/www/sag-was.com/wp-content/plugins/podlove-podcasting-plugin-for-wordpress/vendor-prefixed/twig/twig/src/Template.php(363): __TwigTemplate_17ef9c73bbe43fd30a3fb2a7f0b01245a0473ccb9b80f09d7966c3e0ee1e4b44->doDisplay(Array, Array), referer: https://sag-was.com/geektalk/202-netzneutrale-wetter-katze/
[Mon Nov 16 10:36:21.514961 2020] [cgi:error] [pid 1227] [client 176.94.254.32:55958] AH01215: #1 /var/www/sagwas/data/www/sag-was.com/wp-content/plugins/podlove-podcasting-plugin-for-wordpress/vendor-prefixed/twig/twig/src/Template.php(338): PodlovePublisher_Vendor\Twig\Template->displayWithErrorHandling(Array, Array), referer: https://sag-was.com/geektalk/202-netzneutrale-wetter-katze/
[Mon Nov 16 10:36:21.515416 2020] [cgi:error] [pid 1227] [client 176.94.254.32:55958] AH01215: #2 /var/www/sagwas/data/www/sag-was.com/wp-content/plugins/podlove-podcasting-plugin-for-wordpress/vendor-prefixed/twig/twig/src/Environment.php(372) : eval()'d code(49): PodlovePublisher_Vendor\Twig\Template->display(Array), referer: https://sag-was.com/geektalk/202-netzneutrale-wetter-katze/
[Mon Nov 16 10:36:21.515871 2020] [cgi:error] [pid 1227] [client 176.94.254.32:55958] AH01215: #3 /var/www/sagwas/data/www/sag-was.com/wp-content/plugins/podlove-podcasting- in /var/www/sagwas/data/www/sag-was.com/wp-content/plugins/podlove-podcasting-plugin-for-wordpress/vendor-prefixed/twig/twig/src/Environment.php(372) : eval()'d code on line 43, referer: https://sag-was.com/geektalk/202-netzneutrale-wetter-katze/
[Mon Nov 16 10:36:28.612969 2020] [cgi:error] [pid 1240] [client 173.252.79.31:55964] AH01215: PHP Fatal error: Uncaught Error: Call to undefined function twig_in_filter() in /var/www/sagwas/data/www/sag-was.com/wp-content/plugins/podlove-podcasting-plugin-for-wordpress/vendor-prefixed/twig/twig/src/Environment.php(372) : eval()'d code:43
[Mon Nov 16 10:36:28.613025 2020] [cgi:error] [pid 1240] [client 173.252.79.31:55964] AH01215: Stack trace:

Hoffe, ich konnte helfen.
Beste Grüße,
Josef

1 Like

@ericteubert zumindest kann ich den Menüpunkt aufrufen und (dieser) Fehler kommt nicht mehr. In den nächsten Tagen kann ich mehr sagen.
Lieben Dank für das schnelle fixen.

Axel

Also bei mir (www.der-graue-rat.de) gehts auch mit der 3.1.4 nicht. Dachte erst, es läge am Theme, aber selbst mit nem wordpress-Standard-Theme zeigt er nur Episodenbild und Fehlermeldung.

3.1.0 ist die letzte Version ohne dieses Problem.

Habe die auch gerade wieder als „aktuelle“ Version geschaltet, d.h. ist auch die Version, die man hier über den großen Download-Button bekommt: https://wordpress.org/plugins/podlove-podcasting-plugin-for-wordpress/ Ein Downgrade direkt aus WordPress heraus geht meines Wissens leider nicht.

1 Like

:construction: 3.1.17 wurde gerade released. Wer mutig ist, bitte ausprobieren und berichten :rabbit:

1 Like

Also habe es Mal installiert und wieder aktiviert, kurz geschaut, scheint wieder zu laufen. Werde aber gleich noch Mal den Debug-Modus aktivieren und schauen.

1 Like

Ich habe es auch gerade auf einer betroffenen Instanz probiert. Erster Eindruck: geht :slight_smile:

1 Like

Folgende Fehlermeldung, wenn ich eine neue Folge anlegen möchte:

**Notice** : register_rest_route wurde **fehlerhaft aufgerufen** . Der Definition der REST-API-Route für shariff/v1/share_counts fehlt das erforderliche Argument permission_callback. Für REST-API-Routen, die für öffentlichen Zugriff gedacht sind, benutze __return_true als Berechtigungs-Callback. Weitere Informationen: [Debugging in WordPress (engl.)](https://wordpress.org/support/article/debugging-in-wordpress/) (Diese Meldung wurde in Version 5.5.0 hinzugefügt.) in **meinungsschauspieler.de/httpdocs/wp-includes/functions.php** on line **5229**