[gelöst] Webplayer 5.0.14 wird nicht angezeigt

Hallo liebes Entwickler-Team,

nach dem Update auf Publisher 2.10.0 und Webplayer 5.10.14 sowie der Auswahl des 5er-Players als Standard in den Podlove-Settings habe ich folgendes Problem: Der Webplayer wird nicht angezeigt und auf der Einstellungsseite des Web-Players kann ich keine der Optionen auswählen oder ändern. Aktuell habe ich die Version 4 wieder aktiviert. Habt ihr ähnliche Berichte schon erhalten bzw. ist das hier das gleiche Phänomen?

Vielen Dank für Eure Hilfe
Martin

2 Like

Hey Martin,

kannst du mir ein paar Details zu deiner Wordpress Installation teilen? Hast du evtl. Security Plugins installiert?

Hallo Alexander,
ich nutze Wordpress 5.4.1, Security Plugins nutze ich meines Wissens nicht, es sei denn, Akismet oder Comet Cache fielen darunter. Was könnten sonst verdächtige Plugins sein?
Beste Gründe
Martin

Kannst du mir für einen kurzen Zeitraum den Player aktivieren? Dann kann ich mal schauen wo es klemmt.

Alles klar, ist aktiv – bzw. nicht :slight_smile:

Scheißhalber vielleicht mal das Cacheplugin deaktivieren?

1 Like

Danke fürs aktivieren, ich hab den Fehler glaube ich gefunden, da stimmt irgendwas nicht mit dem Pfad: https://www.staatsbuergerkunde-podcast.deembed.js/?ver=5.0.13

1 Like

OK – aber wie kam das zustande? Habe ich da was verbockt?

Nein ich glaube da hapert es noch an der Logik wie der öffentliche Pfad zur embed.js berechnet wird. In der Zwischenzeit könntest du versuchen den Player via CDN zu beziehen. Solange arbeite ich an einem Fix :slight_smile:

1 Like

Ah, verstehe. Meinst Du die CDN-Einstellung hier?
Podlove_Web_Player_Configuration_%E2%80%B9_Staatsb%C3%BCrgerkunde_%E2%80%94_WordPress

Ich sehe zwar die Einstellungen und das Dropdown, meine Auswahl wird aber nicht angezeigt nach dem Anklicken und “Save” scheint auch keinen Effekt zu haben.

Ok, diesen Zustand hatte ich schon bei @dasistrobert gesehen. Kannst du mir noch ein paar Informationen ala PHP Version, Host usw. zukommen lassen?

1 Like

Hallo Alexander,
ich verwende aktuell php 7.2 auf einem Uberspace (Version 6).

Also ich hatte ein ähnliches Problem gestern.
Bei mir hat folgendes Funktioniert:

  1. Podlove --> Podcast Einstellungen --> Player
  • Web Player automatisch einfügen = Kein automatiches Einfügen
  • Änderungen speichern
  1. Einstellungen --> Podlove Web Player --> Settings
  • Transform Post Enclosure = insert player at the top of the post
  • Save

Dann hat es bei mir funktioniert auf beiden Podacst:
http://rewrite-podcast.de
http://podyssey.de/

Versuch es mal.

Hast Du im Hintergrund was gedreht? :slight_smile: Auf jeden Fall wird der Player jetzt angezeigt und auch die Einstellungen sehen jetzt “aktiver” aus. Würde mich heute Nachmittag mal eingehend damit befassen und kann dann Rückmeldung geben – jetzt aber erst mal Aufnahme :slight_smile:

@Soenke79 Danke für Deinen Tipp, aber ich glaube, @zusatzstoff hat im Maschinenraum was gefixt :slight_smile:

1 Like

Ich hab nichts gemacht, ich glaube das lag am Caching Plugin :smiley:

Das sind die besten Erlebnisse für Entwickler:innen, könnte ich mir vorstellen :slight_smile: Hab’ aber auch nix dran verändert. Hm. Wie gesagt konnte ich jetzt auch die Einstellungen anpassen und hab’ mir auch ein Template gespeichert. Sobald ich aber die Settings verlasse, “vergisst” das Plugin die und ist dann wieder auf “default” gesetzt. Ich kann mein Template zwar auswählen und klicke auf “Speichern”, wird aber nicht online angezeigt und sobald ich die Settings verlasse und wieder reingehe, steht wieder alles auf default. Kann das auch der Cache sein?

Generell will ich schon nachvollziehen warum etwas nicht funktioniert, falls das ein gängiger Fall sein sollte.

Ich glaube das es in deinem konkreten Fall noch etwas an der Integration mit dem Publisher hapert: https://community.podlove.org/t/tutorial-podlove-web-player-5-and-podlove-publisher-integration/2166

Ansonsten muss ich noch was an der Plugin UX drehen da das offensichtlich widersprüchlich ist.

1 Like

Ich hatte das gleiche Problem und es schien ein ähnlicher Grund gewesen zu sein. Irgendeine komische Kombination aus Fast Velocity Minify und Nginx Helper (zum Cache-Löschen). Es kam zu einem JavaScript-Fehler, weil anscheinend das Skript für den Player gefehlt hat. Mit der CDN-Variante hat es dann auch geklappt.

1 Like

Das war dann tatsächlich der Grund – da ich nur [podlove-episode-web-player] im Template angegeben hatte, hat er vermutlich die “default” Templates, Settings und Configs gezogen. Mit Verweis auf meine eigenen klappt es, danke Dir!
Vielleicht auch die Lösung für @kai?

Hm. Ich nutze nicht [podlove-episode-web-player], sondern habe es, wie @Soenke79 gemacht, trotzdem wird nur das default Theme gezogen… was kann ich da machen?