Für mich seltsames Verhalten beim download

Hallo zusammen,

erstmal Danke für das großartige plugin/ podlove web player.

Folgendes verblüfft mich:

Ist die Statistik aktiviert wird bei files | download dieser link beim mouseover sichtbar:

https : //zukunftinarbeit.eu/podlove/file/4/s/webplayer/c/episode/zia002.mp3

download durch Anklicken (linke Maustaste) klappt nicht,

Im firefox 71.0 passiert scheinbar nichts, außer das der player verschwindet

Im chromium 79.0.3945.79 erscheint statt des players
" zukunft-in-arbeit.eu refused to connect."

‘save link as’ (rechte Maustaste ) funktioniert in beiden browsern

Sonst alles ok, Abspielen geht etc.
Ich vermute aber das viele Anwender das nicht verstehen, so wie ich auch nicht

Und wie funktioniert das? Denn ein subdirectory
podlove/file/4/s/webplayer/c/episode/
gibt es ja nicht :slight_smile:
Aber der link funktioniert auch direkt aufgerufen :o

Ist die Statistik deaktiviert:
sieht der link so aus
https : //zukunft-in-arbeit.eu/testtest/wp-content/uploads/zia002.mp3
Jetzt funktioniert alles, auch der download durchs direkte Anklicken (rechte Maustaste)
Aber ohne Statistik. Die finde ich aber sehr nützlich :slight_smile:

Habt ihr bitte Tipps für mich?
Problem 1: rechte/linke Maustaste
Problem 2: meine Unkenntnis bezüglich des links für die Statistik

Danke + Grüße
Mike

Diese Fehlermeldung erscheint in der Entwickler-Konsole:

Laden verboten durch X-Frame-Options: “SAMEORIGIN” von “https://zukunft-in-arbeit.eu/testtest/wp-content/uploads/zia…context=episode&ptm_request=24576249a382&ptm_file=zia002.mp3”, Website erlaubt keine quellübergreifende (cross-origin) Frames von “https://zukunftinarbeit.eu/die-redakteurinnen-der-sendereihe-stellen-sich-vor/”.

Folgende Annahme meinerseits:

  • Die Blog-URL in der Wordpress-Konfiguration steht auf zukunftinarbeit.eu.
  • In Podlove ist allerdings zukunft-in-arbeit.eu konfiguriert im Bereich bei den Medien-Einstellungen (Screenshot siehe unten)

21

Diese Schritte rate ich:

  • Erst mal entscheidet euch für eine der beiden Domain-Schreibweisen (und auch nur mit oder ohne “www.”)
  • Prüft alle Vorkommnisse der URL in Wordpress (am Besten über die Datenbank in den Tabellen posts und config) und schreibt diese auf die eine wahr um.
    • Händisch gilt die Blog-Konfiguration und mindestens Podlove Medien zu prüfen
  • Danach leitet alle anderen (auch mit oder ohne “https” bzw. “www.”) auf die eine gültige Adresse weiter
  • Prüft nochmals alles - und ganz wichtig: Keine Weiterleitungen zwischen den verschiedenen Domains oder Protokollen wenn nicht unbedingt notwendig. (siehe auch Google Podcast kein Stream nur Download möglich [gelöst])

Alternative

  • Der Server muss den Header “X-Frame-Options” senden und den Zugriff nicht nur von SAMEORIGINS (gleicher Domain) erlauben sondern dann müssten da alle erlaubten Domains gelistet werden. Erstere Variante ist aber auch aus Gründe der Suchmaschinenoptimierung besser.
2 Like

Herzlichen Dank für die prompte und richtige Analyse!
Ja, nach einem kurzfristigen Wechsel der URL stimmte das Upload-Verzeichnis nicht mehr.
(Mit Bindestrichen)
Angepasst (Bindestricher entfernt) und es funktioniert.

Deine übrigen Ratschläge werde ich ebenfalls umsetzen.

So macht das Spaß

Viele Grüße, Mike

Bitte, gerne.

Viel Spaß beim Podcasten.

1 Like