Einstellen des Button-Titels (Subscribe/Abonnieren) beim Subscribe Button

Hi,

ich versuche grade, dafür zu sorgen dass der Subscribe Button für den Deutschen Feed (ich habe DE und EN Feeds) das Wort “Abonnieren” anzeigt und nicht “Subscribe”. Derzeit verwenden alle Buttons “Subscribe”.

Ich verwende einen Shortcode zum Einbetten …

[podlove-subscribe-button button="ot-de" ]

und have versucht, da die Sprache einzustellen mittels

[podlove-subscribe-button button="ot-de"  data-language="de" language="de"]

Das hat aber keine Auswirkung.

Hat jemand nen Tipp?

Danke,
Markus

ich vermute mal das Wort “Subscribe” ist eine feste Grafik und kein Text.

Nee, es gibt ja Podcasts, wo “Abonnieren” verwendet wird.

Vielleicht lässt sich das über einzelne Templates umsetzen und dann per Shortcode einbetten.
Bei mir schaut das beispielsweise so aus: {{ podcast.subscribeButton({format: 'rectangle', color: '#ed950d', style: 'outline', size: 'big', language:'de'}) }}

Dokumentation unter http://docs.podlove.org/podlove-publisher/reference/template-tags#podcast
Beispiele unter http://docs.podlove.org/podlove-subscribe-button/

Hi Florian,

was ist denn eine Template (im Unterschied zum Shortcode)? Die Beispiele unter
http://docs.podlove.org/podlove-subscribe-button/ hatte ich gesehen. Da steht auch “Abonnieren”.
Die Page Source zeigt, dass der Button direkt via Script eingebunden ist statt per Shortcode. Ich
verwende einen Shortcode und habe ja auch das language=“de” Attribut. Das scheint aber
keinen Effekt zu haben.

Markus

Ob dieser Ansatz “best practice” ist, kann @ericteubert besser beurteilen. Auch, warum das Attribut language=“de” im Shortcode nicht funktioniert, kann ich nicht sagen.

Ich würde im Wordpress Dashboard unter Podlove >> Templates folgende Vorlagen anlegen:

BigSubscribeButtonEN mit dem Inhalt
{{ podcast.subscribeButton({format: 'rectangle', color: '#000', language:'en'}) }}

BigSubscribeButtonDE mit entsprechend
{{ podcast.subscribeButton({format: 'rectangle', color: '#000', language:'de'}) }}

Die weiteren Parameter (size, style etc) findest du unter http://docs.podlove.org/podlove-publisher/reference/template-tags#podcast im Abschnitt podcast.subscribeButton

Eingebettet werden die Templates dann mittels Shortcode
[podlove-template template="BigSubscribeButtonEN"]
`[podlove-template template=“BigSubscribeButtonDE”]``

Und so schaut das dann aus:

Viel Erfolg!

Edit: Mir fällt gerade ein, dass diese Methode womöglich nicht per se mit unterschiedlichen Feeds funktioniert… :confused:

Vielen Dank Florian!

​​

Ich würde im Wordpress Dashboard unter Podlove >> Templates folgende
Vorlagen anlegen:

​Podlove >> Templates habe ich nicht. Ich verwende nur den Player und den
Subscribe Button,
aber nicht den Rest von Podlove.

Markus​

BigSubscribeButtonEN mit dem Inhalt
{{ podcast.subscribeButton({format: ‘rectangle’, color: ‘#000’,
language:‘en’}) }}

BigSubscribeButtonDE mit entsprechend
{{ podcast.subscribeButton({format: ‘rectangle’, color: ‘#000’,
language:‘de’}) }}

Die weiteren Parameter (size, style etc) findest du unter
http://docs.podlove.org/podlove-publisher/reference/template-tags#podcast
im Abschnitt podcast.subscribeButton

Eingebettet werden die Templates dann mittels Shortcode
[podlove-template template=“BigSubscribeButtonEN”]
[podlove-template template=“BigSubscribeButtonDE”]`

Und so schaut das dann aus:

Viel Erfolg!

Edit: Mir fällt gerade ein, dass diese Methode womöglich nicht per se mit
unterschiedlichen Feeds funktioniert… [image: :confused:]

Rufe das Thema auf
https://sendegate.de/t/einstellen-des-button-titels-subscribe-abonnieren-beim-subscribe-button/3409/6
oder antworte auf diese E-Mail, um zu antworten.

Um keine Benachrichtigungen mehr zu diesem Thema zu erhalten, bitte hier
klicken
https://sendegate.de/t/einstellen-des-button-titels-subscribe-abonnieren-beim-subscribe-button/3409/unsubscribe.
Du kannst den Empfang von Benachrichtigungen per E-Mail auch in deinen
Profil-Eigenschaften https://sendegate.de/my/preferences deaktivieren

Dr. Markus Völter

voelter - ingenieurbüro für softwaretechnologie
voelter@acm.org :: http://www.voelter.de :: +49 (0) 171 / 86 01 869

http://dslbook.org :: Domain Specific Language Engineering book
http://mbeddr.com :: Extensible Languages for Embedded Software
http://omegataupodcast.net :: Science and Engineering in your Headphones

Nein, ist alles Text und passt sich auch der Sprache an. Kann sein, dass hier das Problem ist, dass mehrere Buttons auf der Seite dazu führen, dass nur die Settings von einem Button für alle gelten. Das ist noch ein Bug im Button, der demnächst behoben werden soll.

Vielleicht mag sich @benzimmer mal dazu äußern?

Mag er :slight_smile:

Habe gerade mal auf der Demo Seite die ersten Buttons auf englische Sprache umgestellt. Funktioniert wie hier zu sehen ist: http://docs.podlove.org/podlove-subscribe-button/

Der Bug, den @timpritlove erwähnt bezieht sich nur auf die Farben im Popup.

Auf der Demoseite sind es ja aber Script Tags. Ich versuche es mit dem Shortcode in Wordpress, und da scheint es nicht zu gehen. Wir können gerne mal per Screenshare auf die Wordpress Install und die Verwendung des Button schauen, wenn das weiterhilft.

Der Shortcode in Wordpress ist eher der Bereich von @ericteubert oder?

Der shortcode hat die gleichen Parameter wie der template tag. Ich habe eben folgendes ausprobiert:

[podlove-podcast-subscribe-button format="rectangle" language="de"]
[podlove-podcast-subscribe-button format="rectangle" language="en"]
[podlove-podcast-subscribe-button format="rectangle" language="fr"]

Und bekam 3 Button in den unterschiedlichen Sprachen:

Ich nicht :slight_smile: Ich attache mal Screenshots von den betreffenden Konfigurationen bzw. Codestellen.

Konfiguration des Buttons:

Einbettung per Shortcode in einem Textwidget:

Ah, du benutzt https://wordpress.org/plugins/podlove-subscribe-button/? Das Plugin stammt von @chemiker und verhält sich ggf. anders als der Shortcode des Publishers.

Am besten mal hier nachhaken: https://github.com/podlove/podlove-subscribe-button-wp-plugin/issues

Danke @ericteubert, ich habe ein Issue eingestellt.