Apple Podcastsconnect Feed mit SSL Fehler

Der Feed meines Podcasts hat eine Fehlermeldung. In Podcastconnect steht:

“Incompatible SSL certificate. PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target”

Der Feed ist dieser:
https://corona-wg.de/feed/aac/

und hat auch bis vor einiger Zeit funktioniert. Nun wird er aber nicht mehr aktualisiert seit dem 8.4.
Ich bin als Noob etwas ratlos.

Vielen Dank vorab!

Das ist wohl ein Zertifikatsproblem laut Deiner Fehlermeldung, das wohl irgendwie nicht mehr aktuell oder gültig zu sein scheint.
Wennde das gefixt bekommst, dürfte der Feed vermutlich wieder akzeptiert werden.

Danke. Das Zertifikat ist doch aber in Ordnung oder nicht - zumindest bei mir meckert kein Browser.

Ich meine mich erinnern zu können das Apple im Backend eine ziemlich alte Java Version nutzt, kann sein das die mit sehr modernen Zertifikaten ( u.a. 4096 Schlüssellänge ) nicht zu recht kommt -

1 Like

Bei einem anderen Podcast (gleicher Hoster) mit 4096 bit Schlüssellänge gibt es kein Problem.

Ich hab jetzt eine verblüffende Antwort auf meine Nachfrage bei Apple bekommen. Apple sagt mir, dass es an meinem Let’s encrypt Zertifikat liegt:

Upon further review, it appears the issue being experienced is related to the current SSL certificate being used in your RSS feed URL.
It looks like you are using Let’s Encrypt, and this is not a supported Certificate Authority. You will need to use a different Certificate Authority in order to stream your episodes on Apple Podcasts.

Dass das so nicht stimmt weiß ich selbst, die Seite hat ein funktionierende SSL-Zertifikat und auch andere Podcast verwenden let’s encrypt. Vielleicht kann mir doch irgendwer weiterhelfen?

Hi
ich sehe das der Server gerade, während ich mir das anschaue, ein Update erhalten hat und jetzt wieder funktionieren sollte.

Dennoch zur Dokumentation für andere Projekte.
Problem: valid certification path
Hinweis: “Chain of Trust” oder “certificate chain” ist hier das Stichwort
— Quote ----
Did you know that when you install an SSL certificate, you have to install not only your site’s certificate, but also one or more intermediate (a.k.a. chain) certificates?
– Quote End von unterer WebSite —

Soll heissen dass das Intermediate certificate zwar im SSL Zertifikate angegeben aber NICHT installiert war. Der Server Provider muss hier tätig werden.

Überprüfung
https://whatsmychaincert.com

Lösung:
Installierung des “Lets Encrypt” intermediate Zertifikats auf dem Server.

Hoffe das hilft anderen in Zukunft.
Gruss
JOM

1 Like

Danke für die Antwort. Leider scheint bei mir das korrekte Zertifikat installiert zu sein. So jedenfalls ergibt die Prüfung von whatsmychaincer.com
Vielleicht hilft der Hinweis ja anderen weiter!

Hallo Stefan,
ich hatte am Morgen zuerst folgendes Bild (9:19 Uhr).

Einige checks auch mit Linux tools ergab in der Tat das die Chain definiert war.
Aber das Intermediate Zeit auf dem Server wurde nicht kopiert, so meine Theorie.

Als ich ein zweites Mal die URL im Browser überprüft habe, hatte ich das richtige Bild wie folgt gesehen (10:09 Uhr)
40

Auch konnte ich danach die Chain im Browser sehen.

Wie gesagt ich, vermute das einer der Server Admins das Intermediate in der Zwischenzeit auf den Server kopiert hat.

Nur zur Doku für andere.

Gruss
JOM

1 Like

Das hat mit dem Problem wahrscheinlich nichts zu tun, wenn ich das richtig verstehe, sondern damit, dass ich zwischenzeitlich versuche den Feed ohne SSL auszuliefern, dementsprechend hab ich zwischenzeitlich SSL ganz abgeschaltet. Ursprünglich hat die Seite immer https erzwungen, das ist jetzt zumindest mal aus. Aber SSL aufgeben für den Feed könnte einer der Workarrounds sein.
Die Fehlermeldung bei ApplePodcasts besteht nämlich weiterhin.