Web-Frontend Bind-Adresse/Port und Autoanswer


#1

Hallo,

ich hab mir die aktuelle Version (Standalone v19.03.0-alpha-542.64e688d) mal auf dem Raspi kompiliert. Läuft soweit gut, allerdings hat mein Setup einen VPN-Client drauf und über diesen Weg ist die Kiste von der Ferne verwaltbar. Da wäre es gut, man könnte die Bind-Interfaces/Adresse(n) mit einem festen Port für das Web-Frontend im Config-File ablegen (es geht um das sa_set_str(&srv, “127.0.0.1”, port):wink: . Auch fehlt mir ein Autoanswer-Feature wie bei linphone (-a).
Soll ich einen Patch liefern oder wie ist das bei diesem Projekt üblich?

Gruß Deti


#2

Ein Pull Request wäre sinnvoll. Mach am besten zwei getrennte Issue`s vorher auf https://gitlab.com/studio.link/app/issues

Und beschreibe kurz deinen Ansatz wie du es jeweils lösen willst, dann kann ich gerne vorher mal drüber schauen bzw. meine Ideen dazu beisteuern.

Den Pull Request selbst am besten auf https://github.com/Studio-Link/app/pulls
Da ist ein Review vom Workflow einfacher bzw. möglich.


#3

Woher haste denn die Source?
Ich wäre sehr an der Version interessiert. Kannste bitte 'n Link verraten? Danke.


#4

Der Sourcecode ist auf gitlab: https://gitlab.com/studio.link/app


#5

Oh shit … git.
Mit git kenne ich mich nicht aus. Wie krieg ich da 'n Source Tree zum compilieren?


#6

Du kannst auch einen Download durchführen:

https://gitlab.com/studio.link/app/-/archive/v19.xx.x/app-v19.xx.x.tar.gz


#7

Danke @StudioLink, aber mit “git clone” ging’s auch :slight_smile:

Ist nur nicht die standalone Version, oder?


#8

Sind alle Versionen, also Standalone + Plug-ins.


#9

Ich habe die mit “git clone” erzeugte Soure compiliert, da finde ich kein “studio-link-standalone”.

[root@siffux app-v19.xx.x]# find . -name studio-link-standalone
[root@siffux app-v19.xx.x]#

Ich find nur

[root@siffux app-v19.xx.x]# find . -name “alone
./src/my_include/libbaresip_standalone.a
[root@siffux app-v19.xx.x]#


#10

Dann ist was beim Kompilieren schief gegangen. Da musst halt ein bissl aufpassen.


#11

Really… Ich sehe

checking for pa_simple_flush in -lpulse-simple… no
configure: error: PulseAudio support requires the pulse-simple library!
make: *** No targets specified and no makefile found. Stop.
cp: cannot stat ‘.libs/librtaudio.a’: No such file or directory

Die Library hab’ ich aber …

# find / -name “*pulse-simple*”
/usr/lib/libpulse-simple.so.0
/usr/lib/libpulse-simple.so.0.1.1l

Warum wird die nicht genutzt? Wie kann ich die Nutzung erzwingen?


#12

Du brauchst noch die pulseaudio dev Bibliotheken. Ich glaube unter Fedora heißt das Paket
pulseaudio-libs-devel


#13

Schwere Geburt, danke für die Hilfe. Ich hab’ jetzt ein studio-link-standalone binary.
Komme aber erst später zum Testen, leider.

Update: Test erfolgreich! Whoopie.


#14

Es sei noch erwähnt, dass Raspis sich erst ab Version 3b+ für USB-Audio eignen. Die etwas betagtere Version 3b produziert Aussetzer beim USB-Audio-Capture. Praktischerweise passt der Raspi gut in das Gehäuse eines Behringer U-Phoria UMC202HD. Da brauchts nur ein wenig Heißkleber und ein Eck an der hinteren Blende ausgesägt und schon hat man Audiointerface und Codec in einem Gehäuse mit nur einer Stromversorgung. Aktuell verwende ich ein Linphone, das ich 2013 vom damaligen Codebaum geforked und mit 48Khz Stereo Opus gepatched habe, aber die Chancen stehen gut, dass Studio-Link jetzt zum Einsatz kommt.


#15

Ok, mit echo@studio-link.de erfolgreich, aber

Anruf an einer Mobilfunknummer (via Fritz!Box) liefert:

baresip is ready.
reg: sip:siffux-SL@fritz.box: Register: Destination address required
Register Fail: sip:siffux-SL@fritz.box
UNREGISTERING: sip:bbd1cf17@studio-link.de
DELETE USER sip:bbd1cf17@studio-link.de
using stunserver: ‘stun:bbd1cf17:a43d18a604b98f@stun.studio-link.de’
bbd1cf17@studio-link.de: Using medianat turn' bbd1cf17@studio-link.de: {0/TLS/v4} 200 OK (kamailio (4.3.6 (x86_64/linux))) [1 binding] Register OK: sip:bbd1cf17@studio-link.de call: connecting to 'sip:+491609575xxxx@studio-link.de;transport=tls'.. call: media-natturn’ established
sip:+491609575xxxx@studio-link.de;transport=tls: session closed: 404 Not Found

Die alte Version sagt

baresip is ready.
siffux-SL@fritz.box: {0/UDP/v4} 200 OK () [1 binding]
Register OK: sip:siffux-SL@fritz.box
bbd1cf17@studio-link.de: {0/TLS/v4} 200 OK (kamailio (4.3.6 (x86_64/linux))) [1 binding]
Register OK: sip:bbd1cf17@studio-link.de
call: connecting to ‘sip:+491609575xxxx@fritz.box;transport=udp’…
json: {json: “%H”:%H%sjson: }call: SIP Progress: 100 Trying (/)
call: SIP Progress: 183 Session Progress (application/sdp)
audio: Set audio encoder: PCMU 8000Hz 1ch
audio: enable ausrc resampler: 8000Hz/1ch <-- 48000Hz/2ch
audio: source started with sample format S16LE
audio: Set audio decoder: PCMU 8000Hz 1ch
audio: enable auplay resampler: 8000Hz/1ch --> 48000Hz/2ch
audio: player started with sample format S16LE
audio tx pipeline: alsa —> webapp_mono —> webapp_vumeter —> webapp_record —> PCMU
audio rx pipeline: alsa <— webapp_vumeter <— PCMU
siffux-SL@fritz.box: Call in-progress: sip:+491609575xxxx@fritz.box;transport=udp
call: terminate call ‘2922527cfe739a35’ with sip:+491609575xxxx@fritz.box;transport=udp

Kurz gesagt: Mit der neuen Version ist keine Verbindung über die Fruiz!Box möglich :frowning:


#16

Der Call scheint auf der studio-link.de Adresse rauszugehen, ist der Account von der Fritzbox korrekt ausgewählt und unter den Einstellungen auch online?


#17

Seh’ ich auch so, zumal

reg: sip:siffux-SL@fritz.box: Register: Destination address required
Register Fail: sip:siffux-SL@fritz.box
Nee, nicht online. Warum auch immer. Wenn ich die alte Versiion aufrufe, klappt’s.
Da steht ja auch

siffux-SL@fritz.box: {0/UDP/v4} 200 OK () [1 binding]
Register OK: sip:siffux-SL@fritz.box


#18

Probier mal statt fritz.box die IP Adresse von der Fritzbox. Da .box mittlerweile eine TLD ist und die neue SL Version DNS Auflösung selbst direkt erledigt könnte das schon die Ursache sein.


#19

Yeah! Works! Thanks!