Ultraschall + Auphonic Probleme


#21

Leider habe ich gerade keine mehr von diesen Dateien hier. @auphonic: Irgendeine Ahnung, warum in dem Log was du mir damals geschickt hast “wav @” steht? Müsste da nicht “flac @” stehen?


#22

Zur Festverdrahtung: Ich verstehe euch sehr gut. Ihr wollt die Zahl der zu supportenden Versionen so gernig wie irgend möglich halten, weil ihr die Zahl der zu testenden Kombinationen gering haben wollt. Absolut nachvollziehbare Entscheidung.

Das ist mir auch schon klar. Darum habe ich in diesem Fall auch gar nicht euch um Hilfe gefragt. Ihr wollt mein System nicht supporten, ich bin mir dieser Tatsache bewusst und hab mich darum erst mal direkt an Auphonic gewandt und dann hier im Forum rumgefragt. Ich kann nachvollziehen, dass ihr euch angesprochen fühlt, aber das ward ihr nicht. Hätte ich vielleicht expliziter machen sollen.

Ich bin auch der festen Überzeugung, dass dies kein Ultraschall Bug ist. Ich glaube nicht mal, dass es ein Reaper Bug ist. Das wird irgendeine Bug/Inkompatibilität zwischen der flac lib von Reaper und Auphonic sein.

Ich werde trotz eurer Warnungen mein Reaper immer möglichst aktuell halten. Ich mache das jetzt seid ein paar Jahren so und hatte noch nie ein Problem das nicht kosmetischer Natur war wegen einer gebrochenen Reaper/Ultraschall Kombination. Ich hatte aber schon Probleme weil sich Reaper plötzlich nicht mehr mit meiner macOS Version vertrug. Diese Bugs waren fast undebugbar und traten meist erst nach einiger Zeit auf und haben teilweise Aufnahmen zerstört. Ich verstehe, das ihr eure potentiellen Problemfälle gering halten wollt, aber bitte versteht wenn ich das auch mache. (Ich wäre übrigens nur Milde überrascht, wenn sich mein Problem im Endeffekt als ein Problem zwischen der flac Lib und irgendeiner aktualisierten macOS Komponente wäre, APFS wäre ein Kandidat.)

Ich finde es ein wenig unverschämt, wenn mir irgendein Plugin ungefragt wiederholt Autoupdate von Apps abschaltet. Die Integrität meines Systems ist mir (und meinem Arbeitgeber) extrem wichtig und diese Entscheidung müsste ihr euren Usern überlassen und könnt sie nicht einfach ungefragt überschreiben. Ihr würde ja auch keine Systemupdates abschalten. Reaper ist nicht ganz so extrem, geht aber in die selbe Richtung. Die Situation wird dadurch verschärft, das bei mir auch der Ultraschall Update Check kaputt ist (kann theoretisch sein, dass das eine Inkompatibilität ist, ist aber unwahrscheinlich, da euer Update Check Code unverändert ist) und weder Reaper noch ihr außerhalb von Foren (z.B. in Blogs) über Updates informiert. Ich glaubte ein aktuelles Reaper/Ultrashall zu nutzen, stellte dann aber durch Zufall fest, dass der eine Check nicht funktioniert und der andere ohne Warnung abgeschaltet war. Ich kochte. Wir können nur spekulieren, wie viele eurer User exakt in meiner Situation stecken ohne es zu ahnen.

Ihr Kommuniziert da auch merkwürdig. Einerseits höre ich ein “neue Reaper Version bringen eh keine Features die du brauchst, da ändert sich nicht viel und wir kennen eh jedes Bit und würden dir schon bescheid sagen”, andererseits aber “in jeder Version ändern sich total viele Dinge und wir wissen von nichts, Hell could break loose anytime.” Eine von diesen Aussagen könnte stimmen, beide aber nicht.

Ihr könntet Leute wie mich übrigens auch als Betatester einspannen: “hey, wir supporten dich nicht, aber Bugs kann du abladen”. Dann könnte euren Testaufwand eventuell etwas reduzieren und ihr könntet aufkommende Probleme schon früher sehen, bevor sie in einem großen Release an alle rausgehen.

Denn: wenn dieser Bug tatsächlich ein Ultraschall Bug sein sollte (glaub ich nicht), der irgendwann zwischen Reaper 5.40 und Reaper 5.64 eingeführt wurde von dem ihr nichts wusstet dann kann der in Ultraschall 3.1 möglicherweise versehentlich gefixt sein oder er ist noch da. Mein Geld würde ich auf letzteren Fall setzen.


#23

Danke, die Argumente sind - so dargelegt - absolut stimmig und nachvollziehbar. Aber: im Ergebnis kommen wir da dennoch nicht zusammen. Du hast in der Tat einen Bug in unserem Plugin gefunden: gewünschtes Verhalten ist, dass bei nicht gleicher REAPER Versionsnummer das Laden des Plugins abgeschaltet wird, und damit relevante Teile von Ultraschall nicht mehr funktionieren: vor allem das MP3/M4A Tagging, Export von Kapitelmarken etc.

Das werden wir zur 3.1.1 fixen, im Sinne noch: wirklich (wieder) hart einbauen, die jetzige Unschärfe ist wohl aus unserer Beta-Testphase zur 3.1 reingerutscht als Cockos relativ zügig Releases durchgeschoben hat.

Zur nächsten Version musst du dich dann also entscheiden: entweder auf einem veralternden Ultraschall sitzen bleiben und die 3.1 weiter nutzen dank des Bugs mit aktuellen REAPER-Versionen, oder aber Ultraschall aktuell halten und dafür nur alle X Monate ein Update für REAPER bekommen. Einen Kompromiss sehe ich da nicht, bin aber für alternative Vorschläge offen.

Was man aber festhalten kann: sollte die von uns jeweils verbandelte Version von REAPER Probleme machen, auch und gerade unter neuen Versionen von MacOS, so ist das für uns absolut ein Supportfall, um den wir uns natürlich kümmern. Wenn das dadurch geheilt werden kann, dass man eine dann aktuelle REAPER-Version einsetzt, so werden wir nicht zögern extrem zeitnah eine Service-Release rauszugeben mit aktualisierter REAPER Version.

Ist bisher noch nie notwendig gewesen: wäre dann aber für Dich vielleicht die gewünschte Sicherheit.

Das die Update-Nachricht nicht angezeigt wird, ist wiederum beunruhigend. Die sollte einmal pro Tag angezeigt werden, direkt beim Start. Wenn sie das von einer 3.0 kommend nicht wurde, müssen wir dem nachgehen.

Habe hier mal eine Quickpoll erstellt: https://twitter.com/ultraschall_fm/status/970792268813799430


#24

Darüber kann man sicher reden. Wir schwenken gerade unser ganzes Projektmanagement relativ konsequent auf GitHub um, da hätte man eine brauchbare Schnittstelle.


#25

Das wäre wichtig: bitte beim nächsten mal wegspeichern, sonst können wir hier alle nur theoretisch diskutieren …

Das war nur, weil ich damals zum Testen dein flac in eine wav Datei dekodiert habe mit ffmpeg - das hat mit dem Problem nichts zu tun!


#26

Sie haben Post :sunglasses:.


#27

Hallo! Ich habe mal wieder auseinanderlaufende Spuren. Ich hab das ganze jetzt wie beim letzten mal durch ffmpeg gejagt und auf der einen Spur bekomme ich tatsächlich irgendwelche Warnungen:

WMR128> ffmpeg -i WMR128-001.flac out.flac
ffmpeg version 4.0 Copyright (c) 2000-2018 the FFmpeg developers
  built with Apple LLVM version 9.1.0 (clang-902.0.39.1)
  configuration: --prefix=/usr/local/Cellar/ffmpeg/4.0 --enable-shared --enable-pthreads --enable-version3 --enable-hardcoded-tables --enable-avresample --cc=clang --host-cflags= --host-ldflags= --enable-gpl --enable-libmp3lame --enable-libx264 --enable-libxvid --enable-opencl --enable-videotoolbox --disable-lzma
  libavutil      56. 14.100 / 56. 14.100
  libavcodec     58. 18.100 / 58. 18.100
  libavformat    58. 12.100 / 58. 12.100
  libavdevice    58.  3.100 / 58.  3.100
  libavfilter     7. 16.100 /  7. 16.100
  libavresample   4.  0.  0 /  4.  0.  0
  libswscale      5.  1.100 /  5.  1.100
  libswresample   3.  1.100 /  3.  1.100
  libpostproc    55.  1.100 / 55.  1.100
Input #0, flac, from 'WMR128-001.flac':
  Duration: 04:38:01.56, start: 0.000000, bitrate: 301 kb/s
    Stream #0:0: Audio: flac, 48000 Hz, stereo, s16
Stream mapping:
  Stream #0:0 -> #0:0 (flac (native) -> flac (native))
Press [q] to stop, [?] for help
Output #0, flac, to 'out.flac':
  Metadata:
    encoder         : Lavf58.12.100
    Stream #0:0: Audio: flac, 48000 Hz, stereo, s16, 128 kb/s
    Metadata:
      encoder         : Lavc58.18.100 flac
[NULL @ 0x7fae41001200] sample/frame number mismatch in adjacent frames
[NULL @ 0x7fae41001200] sample/frame number mismatch in adjacent frames
[NULL @ 0x7fae41001200] sample/frame number mismatch in adjacent frames
size=  671663kB time=04:38:01.55 bitrate= 329.8kbits/s speed= 415x
video:0kB audio:671655kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: 0.001205%

Was nun?


#28

Könnte auphonic mich wenigsten warnen wenn es beim Konvertieren einer Datei Probleme gab? Es nervt, das immer erst rauszufinden wenn Leute die Datei durchhören. :frowning:


#29

Dieses Problem ist dir jetzt ja schon seit Monaten bekannt und es wiederholt sich anscheinend auch immer wieder. Da es sonst bei niemanden bis jetzt vorkommt, muss es irgendwie an deinem FLAC encoder liegen.
Wie bereits gesagt, bitte versuche doch mal ein anderes Format als flac zu verwenden (wav, alac oder mp3/aac/opus mit höherer bitrate) - es gibt ja genug Alternativen.

Jein: ffmpeg liefert sehr oft Warnungen (und sehr kryptische), wenn wir usere User diese immer schicken würden, wären sie wahrscheinlich extrem verwirrt … :wink:


#30

Wär das als Zusatzoption möglich für Pro-User, die das gern hätten? So als Opt-In?

Vielleicht würde das @343max dann zumindest hinreichend Infos geben, dass da was braun ist und er nochmal genauer hinschaun müsste…