Twenty Nineteen: Webplayer nicht angezeigt

Ich versuchte, ein neues Theme für den Podcast zu verwenden. Ich hatte bislang das Twenty Sixteen installiert und wollte auf Twenty Nineteen gehen. Wenn ich darauf wechsele, wird der Player nicht mehr angezeigt.

Die Console sagt: “Uncaught ReferenceError: podlovePlayer is not defined”. Interessanterweise wird der Player in der Live-Vorschau zum Theme angezeigt. Es geht dabei um https://insecurity.radio.fm/.

Woran kann das liegen bzw. wie kann ich das fixen?

Hey Jens,

ich habe mir Deine Seite und den Fehler eben angesehen. Die Seite versucht den Webplayer innerhalb Deiner Inhalte zu initialisieren:

<script>
  podlovePlayer(...);
</script>

Die JavaScript-Libraries für Deine Seite, darin sind auch die erforderlichen Methoden für den Podlove Webplayer enthalten, werden aber erst am Ende der Seite geladen.

<script defer src="https://insecurity.radio.fm/wp-content/cache/autoptimize/js/autoptimize_feae97e03034528e8270bbb499524338.js"></script>

Ich vermute daher, dass der notwendige JavaScript-Code einfach noch nicht bereitsteht wenn der Webplayer initialisiert werden soll. Ich kenne mich nicht genau mit Wordpress aus, aber cache/autoptimize hört sich nach einem Plugin an welches die Auslieferung von Wordpress beschleunigen soll. Kannst Du versuchen so eine Einstellung zu finden und vorrübergehend zu deaktivieren?

@ericteubert Eventuell lässt sich die Einbindung des Player an DOMContentLoaded binden?

document.addEventListener('DOMContentLoaded', (event) => {
  podlovePlayer(...);
})

Grüße aus Buchholz.

4 Like

Danke dir. AutoOptimize war der wichtige Hinweis. :slightly_smiling_face:

Die Option sorfgt dafür, dass alles ans Ende verschoben wird:

JS-Dateien zusammenfügen?
Alle verlinkten JS-Dateien zusammenfügen, um sie so zu laden, dass das Rendern nicht blockiert wird? Falls diese Option nicht gewählt ist, werden individuelle JS-Dateien an ihrem Ort verbleiben, aber minimiert werden.

Ich habe die rausgenommen und es funktioniert wieder.

Sehr gut, aber irgendwas scheint an Deinem Setup mit dem Plugin nicht korrekt zu funktionieren. Eventuell deaktivierst Du das Plugin komplett. Im Chrome werden bei mir auf Deiner Seite wohl in einer Endlosschleife 404 Seiten aufgerufen.

Dadurch entstehen sehr viele Requests inkl. Netzwerktraffic (hier 851 Requests, 67 MB…) :rotating_light:

1 Like

Passe ich so an :slight_smile:

5 Like

Ist in Version 5.0.13 mit drin

3 Like