Studio Link - BugBoard

Hi,
in der Standalone funktioniert das Mikrofon mit einer simplen “Apple-Headset an den Audioport vom Macbook”-Setup nicht. Tonausgabe funktioniert.
Übersehe ich etwas?

EDIT: Nach wildem Ausgabegeräte hin und her wechseln. Geht es jetzt. Ich kann den Fehler nicht reproduzieren. Sehe ihn also als gelöst an :wink:

EDIT2: Das interne/externe Mikro vom Macbook muss auf 48k gestellt werden. Dann geht es in der Standalone.

Grüße
Niklas

1 „Gefällt mir“

Richtig erkannt. Arbeite gerade auch an einem Patch der die Samplerate dann hoffentlich immer korrekt einstellt unter OS X.

Vorhin mit dem @Teddy_Gon wieder (bei der Standalone) das Problem gehabt dass er nur links bei uns ankam, das Mikro ist ein Rode Procaster.
Das andere wäre ein Feature Request: ich hatte vergessen eine zweite Spur in Reaper für den zweiten Anrufer anzulegen. Was dann passiert: der Anruf kommt beim 2. Teilnehmer an aber wird gleich wieder beendet. Ist es möglich an der Stelle in StudioLink eine Meldung anzuzeigen zu checken ob genügend Spuren angelegt wurden?

1 „Gefällt mir“

Ich glaube @Teddy_Gon nutzt ein Focusrite 2i2 das hat definitiv das Problem mit dem Stereo-Kanal (ist nämlich auch eines meiner Testgeräte). In der v16.03.0 wird es in der Standalone Version einen Mono Button geben um das Signal zu mischen.

Gute Idee mit der Fehlermeldung bei zu wenigen Spuren, nehme ich gleich einmal in die Roadmap.

2 „Gefällt mir“

Japp nutze das Focusrite Scarlett 2i2.

Standalone hatten wir nur genutzt weil ich kurz vor der Sendung merkte das ich noch das 15.12 VST Plugin in Reaper hatte und aus Bequemlichkeit dann eben schnell die standalone alternativ angeworfen habe weil wir nicht wussten woran anfänglich das Problem lag. War aber mit den zu wenih Spuren bei MacSnider

1 „Gefällt mir“

Hab übrigens eine Lösung gefunden für das “aus der Standalone kommt nur Links Ton” Problem, zumindest in Reaper:

Den Output der Remote Spur einzeln auf den $Kopfhörer legen und dann auf Mono Source 1 umstellen.

1 „Gefällt mir“

Ja genau das entspricht meinem Screenshot von weiter oben. Funktioniert leider nur bei einem Teilnehmer. Die anderen würden ja trotzdem den Mix auf nur einem Kanal bekommen. Mit dem Mono Button wird aber alles wieder gut :wink:

2 „Gefällt mir“

Mein 2i2 am Macbook mit der Standalone Version möchte auch so einen Button. :slight_smile:

Was ist denn da eigentlich die Ursache bzw. das Problem bei dem 2i2 und OSX? Im Audio-MIDI-Setup steht ja eindeutig 2-Kanal, aber wieso kommt es nur auf einem raus? Weißt du da was genaueres?

Viele Grüße
Michael

1 „Gefällt mir“

Das ist eigentlich schon so gewollt, da du ja zwei Mikrofone anschließen könntest und z.B. mit Reaper beides ja auf getrennten Spuren haben möchtest (Stereo Links/Rechts). Ist aber eben nicht für jede Situation das richtige verhalten, dein Steinberg kann glaube ich beides, getrennte Spuren oder gemixed.

Ach ja klar. :smile: DEN zweiten Kanal hab ich gedanklich total ausgeblendet. Ich hätte mir das 2i2 mal genauer anschauen sollen. :blush: Jetzt ist es mir aber klar. Somit erklärt sich dann auch was der Button machen wird.

2 „Gefällt mir“

Wenn ich (unter Linux) in Ardour in mehreren Bussen jeweils ein StudioLink Plugin einsetze und dann mehrere Kontakte anrufe, ist der zweite Anruf verknarzt und der dritten unerträglich verknarzt, während der erste in gewohnter Qualität weiterläuft. Getestet mit freakshow1, freakshow2 und freakshow3 bzw. echo. Irgendwann werden dann auch einzelne Anrufe zugemacht.

Durch Heraufsetzen der Buffersize (getestet von 256 bis 1024) in jack kann man das soweit lindern, dass zwei Anrufe parallel gut funktionieren, aber der Dritte bleibt unerträglich.

Bei echo kommt dann noch ein eigenartiger Rückkopplungseffekt dazu, aber der ist wohl prinzipbedingt, weil das Echo ja bei allen anderen (N-1) Teilnehmern aufschlägt und von dort aus wieder zu allen anderen Teilnehmenr zurückechot. Dann schaukelt sich das so langsam hoch.

Ansonsten funktioniert das Plugin in Ardour seit dem Fix mit dem Funktionsnamenskonflikt sehr gut.

1 „Gefällt mir“

Ich glaube du hattest auf der #community:sub7 erwähnt das du auch eine hohe CPU Last beobachtet hattest, besteht die immer noch?

Die hohe CPU-Last kommt nur, wenn ich Carla als Plugin-Host verwende, nach wie vor. Sobald ich StudioLink als Plugin in Carla einfüge, krallt sich der Carla-Prozess einen CPU-Kern zu 100%. Die DSP-Load von Jack bleibt aber unverändert bei der bei meinem Setup üblichen Grundlast von ca. 5% Prozent.

Wenn ich meine Ardour Testsession mit drei StudioLink-Plugins in drei Bussen starte, bleibt die CPU-Last moderat. Ardour nimmt sich etwa 20% eines Kerns. Die Jack DSP-Last geht auf etwa 15% hoch und steigt jedem StudioLink Anruf um wenige (2-3) Prozentpunkte. Die CPU-Last von Ardour steigt dabei moderat mit auf ca. 30% eines Kerns.

Der Effekt, dass Anrufe zugemacht werden ist anscheinend geklärt. Die Freakshow-Testaccounts legen ja auf, wenn der Clip abgespielt ist. Ich dachte die laufen in Schleife.

1 „Gefällt mir“

Ok damit bewegt sich die CPU Last in einem normalen Rahmen. Kannst du einmal unter Settings das Auto-N-1 deaktivieren, ob das einen Unterschied macht?

Die Auto-N-1-Schaltung hat keinen Einfluss. Weder auf CPU-Last noch auf DSP-Last noch auf das beschriebene Verhalten.

Mal so ganz banal. Wie sieht das eigentlich mit Monitoring in der Standalone-App aus?
Ein Freund hat mich neulich gefragt, wie er sich selber hören kann und ich wusste darauf keine Antwort.

Ich denke Monitoring in der Standalone ist keine gute Idee, da das dann im Rechner geroutet werden muss und man sich da nicht auf gesicherte Latenzen verlassen kann. Wird ganz schnell ganz schlimm je nach Rechner Hardware, wenn die Latenz zu hoch wird.

3 „Gefällt mir“

Richtig, Monitoring sollte am besten über die Audio Hardware selbst stattfinden.

2 „Gefällt mir“

Heute habe ich mir auch mal das Studio Link Plugin für Windows (32bit) geholt, um es in Hindenburg auszuprobieren. (Ja, Ultraschall gibt’s auch. Ich mag Hindenburg schlicht für einige Features, die Ultraschall nicht bietet.) Mein Ziel ist, sattelfest zu sein, sobald das Sputnik-Feature veröffentlicht wird.

Das Plugin lässt sich simpel in Hindenburg einfügen und kann simpel pro Spur als Effekt aktiviert werden. Danach wird’s schon komisch:

In diesem StudioLink-Fenster sollte wohl etwas angezeigt werden? Parallel dazu geht das bekannte Browserfenster auf. Dort erhalte ich keinerlei Pegel. Meine Vermutung: Routing könnte hier das Problem sein?

1 „Gefällt mir“

Ich würde hier auch auf Routing tippen. Die Tage teste ich das mal mit der Testversion. Was passiert wenn du das “StudioLink - lokal” Fenster schließt? Könnte ein Überbleibsel durch das aufrufen des Browsers im Hintergrund sein.