Problem beim Anzeigen des Subscribe Buttons

Hey Leute,

ich habe ein Problem mit dem Subscribe Button auf unserer Seite.

Seit etwa einem Monat (vllt seit dem Update?) wird er nicht mehr angezeigt, sondern eine kleine 404 Seite an selber Stelle ausgeliefert.

image

Auf dem Bild sollten zwei Buttons sein, jedoch werden zwei 404 Seiten ausgeliefert innerhalb des Widgets.

Habe mich durch die ganzen Einstellungen durch geklickt, aber bin nicht fündig geworden.

Was kann man da tun? Bin leider selbst nicht so tief in dem Thema drinnen.

LG Eric

Kann es sein, dass Ihr ein Plugin im Einsatz habt, das im Verzeichnis “gdprpatron” liegt? Darauf scheint die URL für den Subscribe-Button zu verweisen. Da würde ich mal anfangen zu suchen.

Die URL ist jedenfalls nicht originol. :slight_smile:
https://www.termfrequenz.de/wp-content/gdprpatron/hts/cdn_podlove_org/subscribe_button/button.html?id=cae6&language=en&size=big%20auto&style=filled&format=rectangle&podcastTitle=Termfrequenz&podcastCover=https://www.termfrequenz.de/wp-content/uploads/2018/03/termfrequenz-logo-transparent.png&buttonColor=%2366cc66

1 Like

Hi Susticle,

danke für die schnelle Antwort und Hilfe!

Ich bin leider echt nicht so tief in dem Thema drinnen und kann dir da keine weiteren hilfreichen Informationen geben.
In dem Verzeichnis sind noch diverse Plug-Ins enthalten, waren sie aber vorher auch schon als der Button noch funktioniert hatte.

Die von dir geschickte URL führt zu einer Bilddatei, die nicht mehr existiert und eine 404 ausgibt, aber in anderen Fällen existieren die Dateien noch und liefern dennoch eine 404.

Ich bin mit dem Latein etwas am Ende :confused:

Wenn ich das richtig sehe (und das ist nicht sicher), habt Ihr da ein Plugin, das Zugriffe auf externe Seiten auf euren eigenen Server umbiegt.

Die Beispiel-URL, die eigentliche einen Subscribe-Button erzeugen sollte:
http://cdn.podlove.org/subscribe-button/button.html?id=cae6&language=en&size=big%20auto&style=filled&format=rectangle&podcastTitle=Termfrequenz&podcastCover=https://www.termfrequenz.de/wp-content/uploads/2018/03/termfrequenz-logo-transparent.png&buttonColor=%2366cc66

… wird anscheinend verändert zu:
https://www.termfrequenz.de/wp-content/gdprpatron/hts/cdn_podlove_org/subscribe_button/button.html?id=cae6&language=en&size=big%20auto&style=filled&format=rectangle&podcastTitle=Termfrequenz&podcastCover=https://www.termfrequenz.de/wp-content/uploads/2018/03/termfrequenz-logo-transparent.png&buttonColor=%2366cc66

Und da scheint mir irgendwas falsch zu laufen. Wenn ich raten soll, würde ich sagen, Ihr habt ein DSGVO-Plugin, das das macht und im Verzeichnis gdprpatron liegt.

Ihr könntet mal in die Liste der installierten Plugins schauen und nachsehen, ob Dir DSGVO- oder GDPR irgendwo als Stichwort findet und probeweise das Plugin mal deaktivieren. Wenn dann die Subscribe-Buttons kommen, habt Ihr die Ursache gefunden.

Edit: Dieses Umbiegen der URL ist wahrscheinlich durchaus erwünscht, schlägt aber offenbar irgendwo fehl.

1 Like

Du hast es perfekt auf den Punkt gebracht! Das war die Antwort.

Ich habe in dem DSGVO Plug-In jetzt die Einstellungen angepasst und es funktioniert wieder wie vorher!

Vielen lieben Dank für deine Hilfe!

LG Eric

Ich würde jetzt gerne ein “Freut mich!” schreiben, allerdings ist das Problem bei mir noch da.

Besteht bei dir das selbe Problem?

Wir benutzen das DSGVO Patron Plug-In, hier habe ich die Option für das lokale speichern von JavaScript ausgeschaltet und jetzt funktioniert es.

Oh, das war von mir missverständlich formuliert, sorry.

Ich setze es selber nicht ein, sondern bekomme auf Euren Seiten weiterhin die Subscribe-Buttons nicht angezeigt.

Das ist nun absolut Raterei. Aber Du könntest schauen, ob es einen Unterschied macht, wenn Du eingeloggt bist oder nicht.

Für den Fall, dass das beim Testen noch weiterhilft. Jetzt (13:11) sind sie da. :slight_smile:

Wenn Du noch etwas verändert hast, schreibe es gerne hier noch eben auf, damit andere die Lösung auch finden können. Danke!

2 Like