Podlove Web Player Wordpress Plugin v5.1.0 Release

Version v5.1.0 des Standalone Plugins wurde gerade released. Dabei adressiere ich insbesondere Probleme die hier innerhalb der Community gemeldet und diskutiert wurden:

  • Standard Konfiguration, Theme und Template kann jetzt im Plugin definiert werden, alle Player Instanzen die keine explizites Konfiguration/Theme oder Template bekommen verwenden jetzt diese Einstellung
  • Beim erstellen von neuen Konfigurationen, Themes oder Templates kann jetzt eine Vorlage verwendet werden, diese kann nach Erstellung immer noch angepasst werden
  • Weitere Konfigurationen (Subscribe Button mit allen Clients), Themes (Wordpress TwentyTwenty, TwentyNineteen) sowie Templates (Podlove Web Player 4 mit info tab) stehen zur Verfügung
  • Podlove Web Player wurde auf Version 5.1.4 geudpated (:fr: Lokalisierung verfügbar)
  • Im Shortcode kann jetzt auch der Show Titel definiert werden
  • Bug gefixed der verhinderte das Plugin richtig zu deinstallieren

Bitte gebt mir Feedback + Wünsche zu den Änderungen :slight_smile:

10 Like

FYI:

Bei einer Installation, die mir nicht gehört, wurde die folgende Fehlemeldung für jede Player-Instanz zwei Male auf der Seite ausgegeben:

Warning: array_replace_recursive(): Expected parameter 2 to be an array, null given in /xxxxxx/wp-content/plugins/podlove-web-player/includes/class-podlove-web-player-options.php on line 186

Die Aktualisierung des Aufrufs in “Templates” behob dieses Problem.

Auffällig war außerdem, dass der Player über keine Standard-Konfiguration verfügte. Eine Neuinstallation behob dieses Problem. Zur Ursache habe ich keine Idee.

Laut Doku gibts nur eine “show-title” Komponente. Vielleicht wäre eine zusätzliche “show-subtitle” und “show-fulltitle” (title+subtitle) Komponente praktisch?

2 Like

Ich schau mal was sich machen lässt um auf mehr Informationen Zugriff zu bekommen :slight_smile:

1 Like