Podlove Web Player falsche Media URL / Show URL not working

Hallo liebe Podcaster,

ich habe ein Wordpress mit dem neusten PodLove Web Player.

Im Podlove Plugin ist die Media URL: www.meinpodcast.de/media/ (Podcast Folge: e000-nullnummer.mp3) angegeben.
Bei der Erstellung einer neuen Episode wird die Datei auch erkannt und die Duration berechnet.

Leider will der Webplayer auf eine Datei unter diesem Pfad zugreifen:
https://www.meinpodcast.de/podlove/file/4/s/webplayer/c/home/e000-nullnummer.mp3

Weiterhin kommt beim drücken auf den Button “Show URL” nur das:

was habe ich Übersehen?

haste mal bei der Media-URL versucht ein http: vor www.meinpodcastmedia.de/media zu packen? Das ist bei mir immer der häufigste Buggrund bei WP-Artikeln, vielleicht auch in deinem Fall…

Wie wäre die URL zur Episode eigentlich gewesen und ist dort der Podcast auch downloadbar, wenn Du ihn händisch in die Browserzeile eingibst?

Hallo Mespotine,

die Media URL ist natürlich mit HTTP eingetragen: http://meinpodcast.de/media/
Was ich mich halt frage ist, wieso der Show URL Dialog Leer ist (siehe Bild) und der Streaming Player eine ganz andere URL aufrufen will.

Die Episode wird im Episoden Fenster von Wordpress erkannt (Länge wird angezeigt und Grüner haken bei MP3)

Mit den Test-URLs kann man leider nichts überprüfen. Wie lauten die richtigen URLs?

Hi Tim,

sorry

Im MP3 Feed steht:

http://extrakurz.de/podlove/file/4/s/feed/c/mp3/e000-nullnummer.mp3

Media URL ist: http://extrakurz.de/media/

Episode 0 ist: http://extrakurz.de/media/e000-nullnummer.mp3 (aufrufbar).

Podcast URL: http://extrakurz.de

Hier mal noch ein paar Debug Infos:
Website https://extrakurz.de
PHP Version 5.4.45-0+deb7u8
WordPress Version 4.8
WordPress Theme Sparkling v2.3.2
WordPress Database Charset utf8mb4
WordPress Database Collate
Publisher Version 2.6.2
Web Player Version 2.1.0
Twig Version 1.33.2
open_basedir /var/www/web57/htdocs/:/var/www/web57/apps/:/var/www/web57/priv/:/var/www/web57/tmp/:/usr/share/pear/:/usr/share/php/:/tmp/
curl Version 7.26.0
iconv available
simplexml ok
max_execution_time 150
upload_max_filesize 50M
memory_limit 256M
disable_classes
disable_functions show_source, highlight_file, apache_child_terminate, apache_get_modules, apache_note, apache_setenv, virtual, dl, diskfreespace, disk_free_space, disk_total_space, posix_getpwnam, posix_getpwuid, posix_mkfifo, posix_mknod, posix_setpgid, posix_setsid, posix_setuid, posix_uname, proc_nice, openlog, syslog, pfsockopen
permalinks ok (/%year%/%monthnum%/%day%/%postname%/)
podlove_permalinks ok
podcast_settings ok
web_player ok
podlove_cache on
assets

0 errors
1 HINWEIS (no dealbreaker, but should be fixed if possible):

  • The PHP setting “open_basedir” is not empty. This is incompatible with curl, a library required by Podlove Publisher. We have a workaround in place but it is preferred to fix the issue. Please ask your hoster to unset “open_basedir”.

Schalte mal Podlove Analytics für Deinen Podcast aus, falls Du das an hast(schaut derzeit so aus) und schau mal, obs dann vielleicht funzt.

Hallo Mespotine,

mit deaktivierten Tracking geht es nun, muss das so sein?

Ok, zumindest funzt das schonmal :smiley:
Das heißt, das Problem liegt irgendwo bei Analytics.
Kannste mal nen Screenshot der Analytics Einstellungen posten, also mit den Einstellungen, die nicht gehn?

gerne doch!

Ist das der richtige Bereich?

Genau da.

Ok, ich vermute mal, dass Du, als es nicht funktioniert hatte, den obersten Punkt “Tracking URL-Parameter & Statistiken” ausgewählt hattest?

@ericteubert
Vielleicht hast Du da eine Idee, woran es liegen könnte?

Hallo,

genau, diesen Punkt hatte ich gewählt.

Ok, weiter kann ich Dir da leider nicht helfen…da reicht mein Wissen nicht mehr aus.
Aber zumindest funktioniert jetzt Dein Download, solang Du ohne Statistiken erstmal leben kannst…

1 Like