Podcast Coverbild wird nicht angezeigt im Player

Hallo zusammen,

ich habe ein Problem mit der Einbindung eines Coverbild in den Podlove Webplayer (Version 2.6.2).
Das Bild habe ich auf meine Seite hochgeladen und es unter den Podlove Podcast Einstellungen als Bild ausgewählt.
Es wird mir das Bild angezeigt und folgende URL: https://www.marpo.de/wp-content/uploads/2017/03/logo_komprimiert.jpg
Das Bild ist 3000x3000 Pixel groß.

Im Webplayer (2-4) wird das ausgewählte Bild nicht angezeigt. Wenn ich mit der rechten Maustaste auf das fehlende Bild klicke unter Grafikadresse kopieren, erhalte ich folgende URL: https://www.marpo.de/podlove/image/68747470733a2f2f7777772e6d6172706f2e64652f77702d636f6e74656e742f75706c6f6164732f323031372f30332f6c6f676f5f6b6f6d7072696d696572742e6a7067/500/0/0/

Habt ihr vielleicht eine Idee wo hier der Fehler liegt? Das Theme habe ich auch probeweise schon geändert, andere Bilder ausgewählt, Bilder von anderen Servern ausgewählt usw., aber leider bisher erfolglos.

Meine Website wird übrigens bei manitu.de gehostet.

Es wäre fein, wenn jemand die richtige Idee hat! Ich freue mich von euch zu hören…

Viele Grüße

Marco

1 Like

Hi Marco,

hast du schon unter Podlove --> Werkzeuge die Buttons “Caches leeren” und “Reparatur versuchen” geklickt und ein evtl. vorhandenes Caching-Plugin geleert? Das wäre mal die erste Maßnahme.

Hallo Jonas,

das habe ich schon mehrfach gemacht, auch Podlove deinstalliert und wieder neu installiert.

Viele Grüße

Marco

Hmm. Mir fällt ein, dass wir ja auch schonmal Kontakt über die Facebook-Gruppe “Podcasts made in Germany” hatten. Du könntest überlegen, ob du den kostenpflichtigen Support in Anspruch nimmst. Dann würdest du Hilfe im WordPress-Backend bekommen. Mir fällt nämlich nichts ein.

Beim dem Versuch den Podcast bei Itunes anzumelden erhielt ich folgende Fehlermeldung:

Es können keine Fol­gen Ihres Feeds gela­den werden. Podcast-­Grafiken müssen
zwischen 1400 x 1400 und 3000 x 3000 Pi­xel groß sein, im JP­G- oder
PNG-Format und im RGB-Farbraum vorliegen und sich auf einem Server
befinden, der HTTP Head Request erlaubt.

Kann es sein, dass mein manitu.de Server keinen “Head Reque­st” erlaubt?

Doch.

Der Fehler liegt einfach darin, dass der Link in deinem Feed, wie du auch schon im Eingangss-Post geäußert hast, ein toter ist. Wo die URL ins Leere führt, meckert iTunes logischerweise, dass keine Grafik geladen werden kann.

Mir erscheint die URL eben auch schon suspekt. Hast du da irgendwas zum Rewrite der URL konfiguriert o.ä.? Bei meinem funktionierenden Podlove-Feed verweist der Feed auch nicht auf die direkte Logo-URL, aber auf eine auch “physisch” vorhandene Cache-URL: http://www.nerdtalk.de/wp-content/cache/podlove/cf/1893042dc7713af814044e980c2dd1/nerdtalk-der-podcast-ueber-kinofilme_original.png

Aus irgendeinem Grund scheint da der Dateiname zu fehlen. Mit diesem und “3000” statt “500” hinten in der URL bekommst du das gewünschte Bild geliefert:

https://www.marpo.de/podlove/image/68747470733a2f2f7777772e6d6172706f2e64652f77702d636f6e74656e742f75706c6f6164732f323031372f30332f6c6f676f5f6b6f6d7072696d696572742e6a7067/3000/0/0/logo_komprimiert.jpg

(Frag mich nicht, woran das liegt.)

Manitu.de hat mir nun ebenfalls bestätigt, dass der “Head Reqeuest” erlaubt ist :wink:

Hey, ich habe ein ähnliches Problem. Das Episoden-Cover wird im Podcastplayer nicht verwendet.

Ich füge das Beitragsbild beim Erstellen der Episoden ein und habe in den Einstellungen ( Episoden-Assets) auch gefunden, dass das Beitragsbild als Episoden-Cover genutzt werden soll.

https://mintros.de/ (Feed)

Ne Idee was ich falsch mache?