Korrekter Migrationsweg Publisher 2.10.0 + Player 5.0.11

Hi!

Etwas unbedarft habe ich den Publisher auf 2.10.0 aktualisiert und in dem Zuge auch den Player auf aktuell 5.0.11 (von 4.x).

Wie ist der korrekte Migrationsweg? Mein Problem:
Ich bekomme den Player nicht ordentlich gestyled und ich finde keine gute Schritt-für-Schritt Anleitung.

Ich habe ein neues Theme angelegt und dies grob so gestyled wie der Player vorher aussah, aber im Frontend zieht er dies nicht und zeigt immer das Default Babyblau an.

Weiterhin kommt vermehrt ein “Netzwerk Problem” - “Es konnten keine Audio Dateien vom Server geladen werden. Entweder du hast gerade keine Verbindung zum Internet oder die Dateien sind nicht auf dem Server verfügbar.” In der Konsole und auch bei den Network Requests ist nichts auffälliges zu sehen.

Wer kann mich in die richtige Richtung schubsen?

Heyho,

Da die Frage bisher schon öfters gestellt wurde bin ich dabei für die Integration mit dem Publisher ein Tutorial zu erstellen. Das sollte dann hoffentlich einen Großteil der Fragen ausräumen.

5 Like

Oh wow, das wäre natürlich super! Vielen Dank schonmal!

Wenn Du da bitte auch die Templatingmöglichkeiten usw erklären könntest, wäre ich sehr dankbar.

1 Like

Ich habe hier eine Anleitung veröffentlicht: https://community.podlove.org/t/tutorial-podlove-web-player-5-and-podlove-publisher-integration/2166

@schaarsen Das Templating werde ich in der offiziellen Dokumentation nochmal aufgreifen da es unabhängig vom Plugin ist.

3 Like

Danke für die Anleitung. Bei diesem Schritt denke ich hakt es bei mir:

  • Extend the episode.player call by adding the Podlove Web Player 5 parameters config, theme and template parameters
  • example: episode.player({ config: "default", theme: "default", template: "compact" })
    Ich habe das so verstanden, dass ich in meinem Template episode.player durch episode.player ({… ersetze und es dann laufen sollte.
    Bei mir hingegen hat es dazu geführt, dass alle Player verschwunden sind und ich auf Webplayer 4 zurück bin. Was mache ich falsch?

Danke! Das hat mir geholfen!

Schau nochmal genau das kein Leerzeichen zwischen episode.player und ({ config: "default", theme: "default", template: "compact" }) ist.

Danke, jetzt funktioniert der Webplayer 5. Ob dort ein Leerzeichen zu viel war, konnte ich nicht mehr feststellen.

1 Like