[gelöst] Der Shortcode für den Button funktioniert seit heute nicht mehr

Hallo, ich hab den Button per shortcode eingesetzt. Bis heute hat das auch ohne Probleme funktioniert. Jetzt hab ich den Blog SSL fähig gemacht seit dem (ich vermute das es vorher noch funktioniert hat) kann ich den Shortcode in Seiten oder Wigets einfügen, ohne das etwas passiert.

Alle anderen podlove shortcodes funktionieren

Hat jemand Vorschläge wie ich das wieder zum laufen bekomme?

Ich hab das Podlove Publisher Plugin deinstalliert und wieder installiert, jetzt läuft es wieder.
Zusätzlich hab ich schmerzhaft rausgefunden das Itunes SSL überhaupt nicht gut findet :frowning:
Also den Podcast wieder auf http umgestellt.

Dass iTunes http bevorzugt habe ich auch festgestellt. Ich würde aber den Podcast bei https belassen. Insbesondere, weil die Browser in den nächsten Monaten anfangen werden, vor http zu warnen. Ich habe es so gemacht, dass mein Podcast per https und per http erreichbar ist, wobei https der Standard ist. Dann gibst Du bei iTunes http an und alles ist chic.

Hallo real68er, Itunes kommt damit also klar wenn ich keine automatische Umleitung auf SSL mach?
welches Zertifikat nutzt du? Wenn du Wordpress und Podlove nutzt, hast du den die Wordpress internen links auf ssl umgestellt?

Hallo @Matth3s ich nutze ein Let’s Encrypt Zertifikat. iTunes hat den RSS-Feed nicht gelesen, wenn ich eine https-Adresse angegeben hatte. Es klappt aber tadellos, wenn ich die http-Adresse nehmen.

Konkret:
http://wikistammtisch.de/feed/mp3/ OK
https://wikistammtisch.de/feed/mp3/ NICHT OK

Hast du die Links im Backend und in der Datenbank auf ssl geändert? Gab es Schwierigkeiten mit Podlove? Ich hatte das Gefühl (nicht wirklich überprüft) das zum Beispiel die Shortcode Situation mit dem Subscribe auch mit der umstellung auf ssl zu tun hatte. Ich würde ungern den sinnvollen umstieg erneut machen und später wieder ein nicht funktionierendes System haben.

@real68er ich hab es jetzt auch mit letsencrypt so umgesetzt wie du. Ich hab heute noch die Folge von @funkenstrahlen gehört (Funkenstrahlen : Lets Encrypt), der auch auf Uberspace das Zertifikat verwendet und mich schließlich dran gesetzt. Ich lasse wie du auch den Zugang per http:// weiter offen. Danke nochmal für die Infos und dein Beispiel.

Gruß Matth3s

PS Die zweite Einrichtung war in 5 Minuten erledigt :slight_smile: Wenn man es einmal gemacht hat ist das echt Einfach.

1 Like

Hi @Matth3s, schön, dass es jetzt geklappt hat. Ich musste bei der Migration von http zu https auch in der Datenbank Links anpassen, damit kein gemischter Content entsteht, also Seiten, die zum Beispiel aus http-Text und https-Bildern zusammen gesetzt sind.