Feedbegehung: The Doctor's in!


#21

Meins ist gar nicht da! (glaube ich) http://rss.acast.com/americanafureuch


#22

Das wäre eine gute Idee. Danke für die Klärung!


#23

Kaum ist man mal im Urlaub verpasst man das beste… Hoffentlich bin ich noch nich zu spät :wink:
http://ABCoholics.xyz/feed/mp3/


#24

Dankeschön erstmal.

Das hatte ich versucht. Hat wohl nicht geklappt.

Ja, genau. Aber was sonnst? Science, Tech,… es passt alles irgendwie nicht. :disappointed:

Georss! Wie kommt das denn da rein? Ja ich wollte irgendwann was mit den Koordinaten machen, aber es steht da ja schon drin, cool. :grin:

Inhalte sind irgendwie nicht mitgekommen und ich nicht dazu gekommen zu gucken.

Das Bild ist auch eher noch ein Platzhalter, in den Fehlermeldungen von iTunes connect stand das so mit mindestens 1400x1400.

Ich hab schon Episoden auf Halde. :wink:


#25

Vielen Dank vorab Christian!

Wie gesund ist dieser Patient : http://www.pmicc.de/feed/m4a/ ?


#26

Salut,

ich (bzw. der Podlove Publisher) habe bereits Fehler gefunden, jedoch stehe ich ziemlich ratlos vor dem Problem und habe bereits erfolglos viel Zeit mit diesem komische Fehler verbrannt.
Es wird eine full-URL verlangt, wo eine full-URL steht, bzw. Dinge beanstandet auf die ich, so ich das sehe, keinerlei Einflussmöglichkeit habe. Oder habe ich irgendwo irgendwas übersehen?

Es geht um den folgenden Feed:
https://gsa.to/feed/m4a/

Fehlerausgabe im Podlove Dashboard:
[2016-09-13 10:55:41] Validate feed m4a.
[2016-09-13 10:55:41] Warning: Use of unknown namespace: http://podlove.org/simple-chapters, line 1 in Feed m4a.
[2016-09-13 10:55:41] Warning: Image title doesn’t match channel title, line 11 in Feed m4a.
[2016-09-13 10:55:41] Warning: Self reference doesn’t match document location, line 12 in Feed m4a.
[2016-09-13 10:55:41] Error: href must be a full URL, line 26 in Feed m4a.
[2016-09-13 10:55:41] Error: url must be a full URL, line 38 in Feed m4a.

die beanstandeten Zeilen aus dem Feed:
line 26:
<itunes:image href="https://gsa.to/wp-content/cache/podlove/9c/e9d84a1018c0e8d78bdb829214c6e7/gespraechsaufklaerung_original.png" />

line 38:
<enclosure url="https://gsa.to/pod/gsa000.m4a" length="1887842" type="audio/mp4"/>

Das selbe Problem werfen auch die anderen Feeds (mp3, ogg und opus) auf, ich habe versucht auszuschließen dass es am Uberspace Hosting liegt und die Audiodatein woanders hochgeladen, auch das hatte keinen Erfolg.
Ich habe die komplette Podlove Instanz bereits mehrfach neu aufgezogen (PlugIn deinstallation, installation und komplette manuelle Neueinrichtung) alles ohne Erfolg, der Player hingegen und AntennaPod kommen mit dem kaputten Feed klar, nur in Podcastverzeichnisse bekomme ich das so natürlich nicht rein. Apple gibt leider keinerlei Informationen außer “Feed invalid.” zurück.

Über jede Hilfe würde ich mich riesig freuen,
liebe Grüße.


#27

Bevor ich mich heute Abend wieder auf Feeds stürze, in aller Kürze… (Pumuckl!)

Harmlos. “Warning” eben und vor allem deshalb, weil die Damen und Herren des Validators an der Stelle etwas ignorant sind. Namespaces sind praktisch beliebig und dieser hier hat sogar einen Sinn… Ignoriere das.

Nunja… Der Titel des Podcasts sollte, warum auch immer, mit dem Titel des Bildes (wofür auch immer der gut sein soll) identisch sein. Da Du im Titel des Feeds noch zusätzlich das Audioformat herumträgst, wird der Titel des Bildes nie mit dem des Podcasts übereinstimmen. Ignoriere das.

Ich weiß nun nicht, welche Feed-Adresse dem Validator gegeben wurde zur Überprüfung. Es war jedenfalls nicht die, die im Feed steht. Das ist kein wirkliches Drama, so lange Du nur die im Feed befindliche self-rel als Abo-URL in die Welt hinausträgst.

Der Validator mag https nicht. Auch das kein Drama an sich, jedoch könnte es zu Problemen mit dem einen oder anderen Podcastverzeichnis kommen. iTunes ziert sich da mWn noch etwas.

Alles in allem: Keine Panik, das ist alles kein Drama und nur die https-Sache könnte wirklich Auswirkungen haben. Dennoch solltest Du dabei bleiben, ich unterstelle, dass die meisten relevanten Podcatcher kein Problem damit haben.


#28

Auch wenn hier zwar länger nichts mehr passiert ist, würde ich auch gerne mal unseren Feed checken lassen. Sind noch ganz neu im Spiel und haben vor demnächst zu Podigee zu wechseln, aber dennoch:

https://hearthis.at/noisiv-podcast/podcast

Freue mich über Feedback!


#29

Hallo Torge,

sieht soweit zwar gewöhnungsbedürftig aus (weil praktisch alle Text-Felder als cdata geliefert werden), aber da lässt sich im Wesentlichen nicht meckern.

Auffällig allerdings ist ein eindeutiger Bug/ein Missverständnis seitens des Generator-Programmiermenschens…

<enclosure url="http://hearthis.at/noisiv-podcast/noisivpodcast13larslewerenz/listen.mp3?s=Bje" length="5460" type="audio/mpeg" />

Beachte length=“5460”

Das heißt, dass die Datei 5460KByte lang sein sollte… ist sie natürlich nicht. Das Audio hat eine Länge von 91 Minuten und damit 5460 Sekunden. Das Length-Attribut im Enclosure ist aber eine Größeangabe…

Das kann blöderweise dazu führen, dass im Podcatcher vor dem Download 5Mbyte angezeigt werden, obwohl es dann am Ende über 90 werden. Kannst ja mal an hearthis weitergeben :-}


#30

Hallo @eazy,
falls dein Angebot immer noch gilt: Ich habe auf www.nussschale-podcast.de einen neuen Podcast gestartet. Es ist mein erster, deswegen hab ich auf bewährte Mittel zurückgegriffen und hoffe natürlich, dass sich die … naja, bewähren.
Viele Grüße!


#31

EDIT: HAT SICH ERLEDIGT. Lag wohl an einer neuen PHP-Version. Mit der alten klappt der Feed wieder.


Hallo zusammen, seit drei Jahren ist mein Podcast online und eigentlich gabe s nie Probleme.

Heute habe ich mich mal bei Apple eingeloggt, weil ich irgendwann mal die Seite auf https umstellen wollte und gecheckt habe, ob ich überhaupt noch meine Zugangsdaten habe. :wink:

Beim Einloggen sagt Apple, dass mein Feed einen Fehler hat:

http://www.feuerglutundherzblut.de/feed/aac/

Apple sagt:

Can’t parse your feed. Invalid XML: Error on line 2: The markup in the document following the root element must be well-formed.

Daraufhin war ich mal auf castfeedvalidator.com und der meckert auch:

Sorry

This feed does not validate.

line 1, column 0: Undefined root element: br [help]
    <br />
line 2, column 0: XML parsing error: <unknown>:2:0: junk after document element [help]
    <b>Warning</b>:  A non-numeric value encountered in <b>/www/htdocs/ ...

Ich habe nichts umgestellt und nutze Podlove Podcast Publisher 2.4.5 (die momentan aktuellste Version).


#32

Ach Du meine Güte, sorry, das hab ich glatt überlesen :frowning:
Das Ergebnis:

Die Seite www.nussschale-podcast.de funktioniert nicht
www.nussschale-podcast.de hat Sie zu oft weitergeleitet.


#33

Danke für’s noch ran denken :slight_smile:
Hast du eine Ahnung, woran das liegen kann? Ich habe gestern einen HTTPS-Redirect via .htaccess Datei eingerichtet, kann es sein, dass das Probleme macht?


#34

Was passiert:

http://www.nussschale-podcast.de/feed/m4a/ leitet auf https://www.nussschale-podcast.de/feed/m4a/ weiter.
Und das wieder zurück… und dann geht die Fahrt von vorne los…


#35

Fällt dir eine andere Lösung ein als den Redirect zu https rauszunehmen? Die Feeds müssen erst mal auf http bleiben, weil iTunes $boeseworte ist.


#36

Ich verstehe nicht, was Dein Problem ist. Wenn Du https UND http haben willst, dann ist das ja iO, aber eine Weiterleitung ist dann unnötig.

Also mach die weg und gut :slight_smile:


#37

Naja, es soll eigentlich alles HTTPS sein, nur der Feed muss auch über HTTP erreichbar sein (weil iTunes). Durch Links auf der Website (ich konnte noch nicht alle händisch finden) kommt man leider häufig wieder nur auf HTTP Seiten und gerade von externen Links kann ich es gar nicht kontrollieren. Deswegen macht der Redirect schon Sinn.
Wenn er allerdings meinen Feed kaputt macht, bin ich wohl machtlos. Lieber wäre es mir, den Feed aus dem Redirect auszuschließen oder so. Aber meine technischen Fähigkeiten was sowas angeht …
Ich mach’s erst mal wieder raus, vielleicht hat ja jemand noch eine Idee :slight_smile:
Danke auf jeden Fall für den Hinweis, alleine hätte ich das nie gemerkt!
Update Jetzt sollte es klappen (sprich: Redirect ist weg)