Feed wirft Fehler

Moin,

ich hab hier eine kleine Katastrophe… denke es hat was mit dem Publisher zu tun.

Also…
Habe gestern von Wordpress 4.9 auf 5.4 geupdated.
Podlove-Plugins sind auch alle up-to-date.

Jedoch habe ich seid dem Fehler-Meldungen vom Player (v4), aber der Player funktioniert soweit, auch wenn ich gerade nur den Standard-Player sehe… ist mir auch grad egal, denn mein Feed geht nicht mehr.

Bekomme bei https://castfeedvalidator.com/?url=https://www.couch-entertainment.de/feed/mp3/
diese Fehler:

FATAL: Invalid content type for feed. Did not finish feed tests.
WARNING: It took your feed 2 seconds to download.

In der Android-App “Podcast Addict” wird mir das hier angezeigt:
“Broken RSS feed: Doesn’t look like a valide RSS feed… First Tag: br”

Ich weiß grad gar nicht wo ich schauen soll, Einstellungen im Publisher sind alle ok und unverändert, soweit ich das sehe. Oder hat es doch mit den Player-Fehlern zu tun?

HILFE!

P.S.
Fehler des Players:
Warning : array_replace_recursive(): Expected parameter 2 to be an array, null given in /www/htdocs/w00ceae5/wp-content/plugins/podlove-web-player/includes/class-podlove-web-player-options.php on line 186

Warning : array_replace_recursive(): Expected parameter 2 to be an array, null given in /www/htdocs/w00ceae5/wp-content/plugins/podlove-web-player/includes/class-podlove-web-player-options.php on line 186

Falls das hilft, was meinen kaputten Feed angeht?

Hallo Stefan,

in Deinem Feed werden auch die PHP Warnungen ausgegeben, dadurch ist es kein gültiger Feed mehr.

curl -s 'https://www.couch-entertainment.de/feed/mp3/' | head -n7

Warning:  array_replace_recursive(): Expected parameter 2 to be an array, null given in /www/htdocs/w00ceae5/wp-content/plugins/podlove-web-player/includes/class-podlove-web-player-options.php on line 186
Warning:  Cannot modify header information - headers already sent by (output started at /www/htdocs/w00ceae5/wp-content/plugins/podlove-web-player/includes/class-podlove-web-player-options.php:186) in /www/htdocs/w00ceae5/wp-content/plugins/podlove-podcasting-plugin-for-wordpress/lib/feeds.php on line 38
Warning:  Cannot modify header information - headers already sent by (output started at /www/htdocs/w00ceae5/wp-content/plugins/podlove-web-player/includes/class-podlove-web-player-options.php:186) in /www/htdocs/w00ceae5/wp-content/plugins/podlove-podcasting-plugin-for-wordpress/templates/feed-rss2.php on line 8

Bei der Fehlermeldung mit array_replace_recursive liegt es wohl an den Optionen die für das Plugin nicht korrekt ermittelt werden können.

Code dazu auf GitHub: https://github.com/podlove/podlove-web-player-wp-plugin/blob/29cc9c83167a627e607a095e676b56f7577ac7ba/src/plugin/includes/class-podlove-web-player-options.php#L178

Das Problem haben wohl auch andere Seiten: https://www.google.com/search?q=class-podlove-web-player-options.php+on+line+186

Vielleicht können Dir @ericteubert oder @zusatzstoff hier weiterhelfen.

Als schnellen Workaround könntest Du versuchen die Warnungen von PHP/Wordpress zu unterdrücken. Ist nicht schön, sollte auch kein Dauerzustand sein.

https://aristath.github.io/blog/wp-hide-php-errors

Grüße aus Buchholz.

1 Like

Hi, danke für die Infos, aber Warnungen unterdrücken löst das Problem ja erstmal nicht.
99% der Hörer kommen über den Feed, da ist für mich das Aussehen vom Blog erstmal Nebensache. :wink:

Hast du es einmal versucht?

Die Warnungen werden ja dann auch im Feed ausgeblendet und der Feed wäre wieder korrekt lesbar.

Vermutlich läuft dann auch der Player wieder, momentan wird durch die Warnung da auch ungültiges JSON zurückgegeben.

https://www.couch-entertainment.de/dystopie/?podlove_action=pwp4_config

Offenbar sind auch diverse Pfad-Einstellungen nicht korrekt, Deine Seite versucht: https://www.couch-entertainment.deembed.js/?ver=5.1.1 aufzurufen.

Nein, aber werde ich jetzt mal, wenn es hilft bin ich erst mal beruhigter :wink:

1 Like

Es gab bei einigen Instanzen Probleme wo WordPress die Optionen nicht richtig initialisiert hat. Du könntest mal versuchen das Podlove Web Player Plugin zu deinstallieren und wieder zu installieren. Das resetted alle Optionen und initialisiert den Default.

1 Like

Dieser Workaround von @knoxmic hat geholfen! Vielen Dank nochmal dafür!
Das ist erstmal gut.

@zusatzstoff:
De- und Neu-Installieren habe ich auch schon überlegt, möchte aber noch abwarten, ob es eine bessere Lösung für das Problem gibt, bevor ich alles neu konfigurieren muss.