Feed validation

Tag zusammen, ich melde mich mit einem recht verworrenem Problem,

ich habe ein “altes” (Das Bildungslücke) und ein aktuelles Podcastprojekt (ABCoholics).
Für die Umsetzung habe ich auf einem Webspace (uberspace) zwei Ordnerstrukturen in denen jeweils eine Wordpress-Installation und die Podcast-Audiofiles liegen.
Das hat auch alles eine ganze Weile lang gut funktioniert, bis wir die Link-Struktur auf sinnvolle URLs umgestellt haben.
Aus “grus…uberspace.de/…/Folge_A” wurde dann also “ABCoholics.xyz/Folge_A” (ich hoffe, das ist verständlich).
Dann war es so, dass das aktuelle Projekt problemlos mit neuem Feed weiterlief. Das alte Projekt hat jedoch seine Aktivität eingestellt.
Der Feed spuckt keine Daten mehr aus und auch über den Webplayer kann ich nichts mehr anhören (er beginnt zu laden, tut das aber in Endlosschleife).
Mir werden die einzelfiles als valide angezeigt, der Feed jedoch nicht (Screenshot).

In den Einstellungen, den hinterlegten Adressen etc. ist alles in beiden Projekten gleich angelegt, hier kann ich keinen Fehler entdecken.

Kann mir jemand von euch eine “Alter, du musst auf XY klicken” Lösung anbieten oder hätte Zeit und Lust sich das mal genauer anzuschauen?

Ich bedanke mich in der vagen Hoffnung auf so ein dämliches Problem eine leichte Lösung zu erhalten :slight_smile:
Adrian

Spontan (mobil ohne groß prüfen zu können) würde ich sagen, dass da nur was in Deinen DB Settings durcheinandergekommen ist und die Permalinks noch nicht refreshed sind. Ich hatte das auch mal. Sollte sich durch Warten lösen.
Da das aber nur so subotimal ist, kann man das auch manuell anstoßen. Ich weiß nciht mehr genau ob ich das über Cronjobs geregelt habe. Aber ich glaube es gab irgendwo einen Button "Datenbank aktualisieren)

Spontan habe ich das mal rausgekramt, da der Link aus meier Historiy war und ich mich an die Seite erinnere, sollte der Link und die Anleitung da funktionieren.

Rufe http://www.deinewebsite.com/wp-admin/upgrade.php auf. Dies gilt für den Fall, dass die WordPress-Installation im Root-Verzeichnis erfolgen soll. Hast du WordPress in ein Unterverzeichnis installiert, muss zwischen „deineseite.com/“ und „wp-admin“ noch das Verzeichnis angegeben werden. Also z.B. http://www.deineseite.com/wordpress/wp-admin/upgrade.php.
Dort sollte jetzt „Datenbankupdate erforderlich“ stehen. Klicke auf „Upgrade WordPress“ und die Aktualisierung beginnt.
Es kann einige Sekunden dauern, bis alles aktualisiert wurde.

Und den Link kann ich Dir auch auf die Schnelle zuwerfen:

Ich hoffe, dass Dir das helfen konnte.

Wie gesagt ich erinnere mich, dass ich das Problem auch mal hatte.

Ach und, was mir gerade noch auffällt: Du hast die Domain geändert? Das checkt WP irgendwie nicht und ändert die Basic URL in der Datenbank nicht. Das kannst Du mit Datenbankzugriff manuell machen, also ändern.
Aber dazu gibt’s auch ein Plug In, in etwa sowas: https://de.wordpress.org/plugins/automatic-domain-changer/

Danke schonmal, ich prüfe mal deine Lösungsvorschläge und melde mich (hoffentlich) mit Erfolgsmeldungen :slight_smile:

1 „Gefällt mir“

Na, jetzt hat mein Kollege das Problem beseitigt und ich weiss nicht mit welchem Lösungsansatz…
Ich werde ihn bei Gelegenheit mal fragen, aber so oder so: 1000 Dank für die Lösungsvorschläge!

1 „Gefällt mir“