Episoden werden nicht auf Übersichtsseite/ landing page angezeigt

Hallo zusammen,

leider bekomme ich keine Übersicht aller Podlove-Episoden auf einer Seite mehr zustande – weder über die reguläre Publisher-URL, noch über eine Archiv-Seite. Ich habe sämtliche Einstellungen und Varianten probiert und hoffe, dass mir jemand helfen kann. Vorneweg: Ich vermute einen Clinch zwischen dem Plugin und meinem Theme.

Hier ein paar DETAILS:
Theme: Panorama-Theme
Plugins: CryptX, GRAND Flash Album Gallery, Podlove Podcast Publisher
neueste Versionen und Updates

EINBINDUNG des Podcasts:

  • ich habe eine Seite angelegt, die .com/podcast heißt und denselben slug hat wie die “Publisher URL” (-> Podcast Settings -> Directory)
  • die Archivseite mit demselben slug habe ich deaktiviert (-> Expert Settings -> Website -> Episode Pages -> Enable episode pages -> x)
  • Als “Podcast landing page” (Einstellungen s. o.) ist die Podcast-Seite angegeben

PROBLEM: Es zeigt mir zwar die einzelnen Episoden auf den jeweiligen Episoden-Seiten mit Player und pipapo an, aber die originäre Podcast-Seite, auf der alle Episoden erscheinen sollten, erscheint nicht.

VARIANTEN, die ich zur Fehlerfindung bereits ausprobiert habe:

  • andere landing page einstellen: Episoden erscheinen auch auf keiner anderen Seite in meinem Menü
  • Text von Podcast-Seite löschen, sodass die Seite leer ist: funktioniert nicht
  • slug ändern (sowohl bei der Seite als auch in den Einstellungen bei der Publisher-URL) bzw. neue Seite anlegen: nada
  • Podlove de- und dann wieder aktivieren (dasselbe mit allen plugins): hat dazu geführt, dass mein Cover wieder angezeigt wird, was davor auch nicht funktioniert hat. Yipeah!
  • Episoden einer bestimmten Kategorie zuordnen und die Kategorie als Reiter dem Menü anhängen: funktioniert zwar theoretisch aber die Anzeige ist gruselig [1]

Meine nur halb-hübsche-Lösung:

  • ich habe die Episoden als Links auf der Podcast-Seite eingebunden
  • die Episoden hängen außerdem (da nicht so viele) dem Menübutton als Unterordner an

Aufgrund von [1] vermute ich einen Kollision irgendeiner mir nicht zugänglichen Art zwischen Theme und Plugin.

Ich hoffe, jemand kann helfen.

Grüße in die Runde

Leonie

Was ist denn der Inhalt der Seite .com/podcast? Der wird ja auf deiner Startseite jetzt angezeigt. Wenn die Seite leer ist, kann dein Blog auch nichts anzeigen.

Das scheint mir des Rätsels Lösung zu sein.

Wenn ich dich richtig verstehe, soll das Ergebnis deiner Unternehmungen sein, dass Besucher deines Blogs gleich eine Liste aller Podcast-Episoden bekommen. Die Lösung wäre entweder alles in den Grundeinstellungen zu belassen, dann sehen Nutzer der Seite eine einstellbare Anzahl an Episoden untereinander und Links, um tiefer zu navigieren, oder du benutzt die “Episode pages”, die du deaktiviert hast (?). Wenn damit eingestiegen werden soll, aktiviere die Episode pages und wähle sie im Dropdown-Menü der Podcast landing page aus.

Episodenlisten, wie du sie als Behelf auf die Startseite gebaut hast, lassen sich übrigens hervorragend mit Shortcodes oder Templates automatisieren.

Hallo Lars,

Danke für Deine Hilfe!

Das verstehe ich nicht ganz. Meine Startseite ist eine statische Seite in meinem Blog, die mit dem Podcast nichts zu tun hat. Die .com/podcast-Seite ist als eine Extra-Seite angelegt und erscheint, wie andere Seiten auch, im Menü. Und die .com/podcast-Seite ist, wie gesagt, in den Podlove-Einstellungen als landing-page für die Episoden eingestellt.
Ich habe ausprobiert, die Seite sowohl leer zu lassen als auch etwas dazu zu schreiben (was dann ja vermutlich oberhalb der Episoden angezeigt werden müsste) – funktioniert beides nicht.

Leider nein. Wenn die Archiv-Seite genauso wie die podcast landing page heißt, nämlich .com/podcast und ich sie zusätzlich aktiviere, bleibt die Seite schwarz. Vermutlich, weil meine angelegte Podcast-Seite mit der Archivseite aufgrund desselben Namens konkurriert.
Aber auch, wenn ich die Archiv-Seite umbenenne, passiert auf der neuen Seite nichts. :-/

Genau.

Wenn ich die Grundeinstellung behalte, passiert eben leider nichts. Also die Seite wird nicht mit den Episoden angezeigt. Genau das ist ja mein Problem.

Wie gesagt, funktioniert leider nicht.

Ha! Das ist im Prinzip genau das, was ich suche. Ich habe jetzt einfach manuell eine Episoden-Liste in die Seite gepflanzt. Hätte ich ja auch mal selbst drauf kommen können. Ttausend Dank für den Tipp! :smiley: Sieht jetzt sogar noch schöner aus als ich erwartet habe.

Über Umwege zu einer anderen Lösung. Merci!

Ah! Ich bin davon ausgegangen, dass dein Blog nichts ausser dem Podcast zeigt, sorry.

[quote=“Leonie, post:3, topic:2853”]
Die .com/podcast-Seite ist als eine Extra-Seite angelegt und erscheint, wie andere Seiten auch, im Menü. Und die .com/podcast-Seite ist, wie gesagt, in den Podlove-Einstellungen als landing-page für die Episoden eingestellt.[/quote]

Hier gibt es wohl ein generelles Missverständnis: Wenn du eine Liste aller Episoden im Stile einer Blog-Seite (also alle Episoden als volle Artikel untereinander weg) anzeigen lassen willst, musst du nichts weiter tun, als in den Expert Settings die Episode pages zu aktivieren und die im Podlove Menü angegebene Adresse im Browser aufrufen (standardmässig BLOG-URL.de/podcast). Das erzeugt dann sowas. Wenn du jetzt noch eine reguläre Seite mit der gleichen Adresse erzeugst, kommt es natürlich zu Konflikten. Podcast landing page kannst du im Grunde ignorieren, wenn du eh mit Links im Menü arbeitest.

Also: Episode pages aktivieren, sicherstellen, dass es keine reguläre, statische Seite mit der gleichen Adresse gibt, die Seite im Browser aufrufen. Wenn der Link zur Seite im Menü erscheinen soll, musst du ihn manuell dort hinzufügen.

Beides funktioniert nicht, weil das Archiv, das du haben willst, automatisch erzeugt wird. Du musst im Grunde nichts mehr tun, als oben beschrieben. Wenn es noch etwas Text sein soll, benutze lieber Shortcodes und Templates auf einer regulären, von dir selbst gebastelten Seite (die Anzeige kompletter Episoden-Einträge wird mit steigender Episoden-Zahl eh extrem unübersichtlich).

Hallo Lars,

vielen Dank erneut für Deine Antwort!

Vielleicht stehe ich auf dem Schlauch: Ich habe die von mir selbst angelegte Seite BLOG-URL.com/podcast kurzzeitig gelöscht (damit keine Konkurrenz entsteht) und konnte dann aber in den expert settings nicht “episode pages” aktivieren, da das ausgegraut war. Aktivieren konnte ich “episode pages” nur, wenn ich ein Häkchen bei der Archiv-Seite gemacht habe. Dann erschien aber nach wie vor nichts – sowohl auf der .com/podcast-Seite als auch auf der Archivseite…

Aber wie schon im vorherigen Eintrag geschrieben ist mein Problem ja dank Deiner Hilfe jetzt sogar schöner gelöst als ich gedacht hätte. :slight_smile:

P. s. Ich glaube, dass es wirklich einen Clinch mit meinem Theme gibt. Denn ich habe gerade entdeckt, dass es einen Unterschied gibt zwischen “Seite nicht gefunden” (zum Beispiel, wenn ich die Archivseite url.com/podcast nenne und gleichzeitig eine manuell eingerichtete url.com/podcast Seite habe, wenn beide also konkurrieren) und einfach einem schwarzen Hintergrund. Wenn ich nämlich die Archivseite aktiviere und so benenne, dass keine Konkurrenz entsteht, also zum Beispiel url.com/archiv, dann gibt es nur einen schwarzen Hintergrund, aber keinen Hinweis darauf, dass die Seite nicht gefunden werden konnte.

(Ich weiß, dass du die Sache anders gelöst hast, aber mich beschäftigt das trotzdem :wink: )

Was meinst du mit “Häkchen bei der Archiv-Seite”? Welche Beschriftung hat das bei dir genau. Der Abschnitt für die episode pages sollte so aussehen:

Wenn man den Haken entfernt, verschwindet der Teil mit der URL. Was genau wird ausgegraut?

Ja, das verstehe ich. Ich bin trotz meiner Lösung auch noch nicht ganz glücklich.

Ich habe mich wahrscheinlich ungenau ausgedrücjt. Fakt ist: Wenn ich Episode pages aktiviere, dann erscheint nichts auf der Seite. Keine Fehlermeldung, sondern einfach nichts. Ich habe die Episode pages mit url.com/archiv aktiviert, damit sie nicht in Konkurrenz zu meiner url.com/podcast Seite kommt.

Ausgegraut war, das hatte ich falsch verstanden, “Episode pages” unter der Option landing page.

Hoffe, dass das jetzt klarer formuliert war. Eine Antwort darauf, warum die Episode page nicht funktioniert, habe ich nicht. :-/