Apple Podcasts zeigt demnächst Transkripte an

Apple hat angekündigt, dass man in Apple Podcasts bald das Transkript mitlesen kann. Wenn man keins mitliefert, wird es automatisch erstellt:

Wie die Qualität der Transkripte von Apple ist wird man sehen müssen (bei Spotify sind sie unfassbar schlecht, gegeben das Open Source Tools wie whisper von OpenAI das viel besser hinbekommen).

In any case: Man kann seine eigenen Transkripte in VTT oder SRT über den Feed ausliefern. Wäre super, wenn podlove publisher das implementieren würde. Das VTT Asset gibt es ja und der Podlove Player nutzt es.

Unter https://help.apple.com/itc/podcasts_connect/#/itcb54353390 lese ich:

<podcast:transcript> A link to the episode transcript in the Closed Caption format. Apple Podcasts will prefer VTT format over SRT format if multiple instances are included.

You should use this tag when you have a valid transcript file available for users to read. Specify the link to your transcript in the url attribute of the tag. A valid type attribute is also requried. Learn more about <podcast> namespace RSS tags on the Github repository.

Options for displaying transcripts are available in Apple Podcasts Connect for each show. Learn more.

1 „Gefällt mir“

Auf Mastodon schreibt Podlove, dass alles schon soweit bereit dafür ist, wenn man das transcripts-Modul nutzt:

Ja der Podlove Publisher macht das alles schon seit drei Jahren so wie es jetzt beschrieben wurde. Macht allerdings den Eindruck dass die Podcasts App das in der aktuellen Beta (noch) nicht richtig umsetzt.

1 „Gefällt mir“

Muss ich, um eigene Transkripte einbinden zu können, so eine Pro-Mitgliedschaft bei PodcastsConnect haben? Habe das gerade mal versucht einzubauen, komme aber nicht weit.
https://vault.uber.space/index.php/s/PAXrtPpRoB5bNEw

Ich glaube der Button ist nur dafür da bei Abos Audio hinzuzufügen und hat mit den Transkripten nichts zu tun.

Das eigentliche Rätsel ist, warum bei den „Bereitgestellt“ das von uns bereitgestellte Transkript nicht erscheint. Da steht nichts davon, dass das Feature noch nicht geht, von daher geht es vielleicht doch schon?

Mein Tip wäre: wir sollten im Podcast-Feed nur einmal „podcast:transcription“ stehen haben. Ich habe den Verdacht, dass drei Einträge (derzeit der Standard im Publisher) Apple verwirren.

Da hast Du vermutlich recht - obwohl die UI das nicht so klar macht. Auf dem Folgen-Screen gibt es diese „Zweiteilung“ bei den Folgen-Details


Da sind „Folgen-Details“ und „Abonnenten*innen-Abo“ zwei separate „Buttons“ aber wenn ich links klicke und was anpassen will über „Bearbeiten“, kommt auch der „Wirf mal Geld ein Screen“.
Ich frage mal nach bei Apple übers Formular.

Die Einstellung dafür findet sich bei mir in Podcastconnect unter „Availability“ ganz unten. Der Default ist „Only display auto-generated transcripts by Apple“ (warum auch immer).

Genau, das ist die globale Einstellung, aber Du kannst pro Folge zumindest auch noch mal sehen, was zur Verfügung steht. Und da tauchen trotz dieses Settings bislang maximal die Auto-Transkriptionen auf bei mir.

1 „Gefällt mir“

OK, alles klar. Jetzt bin ich an der gleichen Stelle angekommen an der ihr seid. Auf den Episodenseiten kann ich bei der letzten Folge ein Auto-Transkript sehen (welches soweit gut aussieht!). Das Feld „Provided“ ist aber leer, wie in dem kleinen Video.
Fragt sich natürlich noch, wie lange man nach dem Umstellen des globalen Settings warten muss, bis Apples Datenbank das mitgelieferte Transkript auch enthält/entdeckt. Kann ja sein, dass die da nochmal irgendwas drauf laufen lassen wollen, wie z.B. irgendeinen Inhaltscheck, aber ihr habt wahrscheinlich schon ein Weilchen gewartet.

1 „Gefällt mir“

Noch eine Sache ist mir in Podcastsconnect aufgefallen: Mein Podcast zeigt bei Copyright „-“ an, also keins. Und in der Tat ist im Feed das Feld leer, also <copyright></copyright> steht im Feed.

In den Podcast-Einstellung in Podlove heißt es „Copyright Hinweis. Wenn du das leer lässt, wird ein Standard Copyright Hinweis angezeigt. Dies wird von Apple Podcasts Connect gefordert.“

Durch ausgegrauten Text wird suggeriert, der Standardhinweis wäre „© 2024 Thomas Kahle“, aber das funktioniert anscheinend nicht. Ich habe dann genau diesen Text eingetragen und jetzt steht das auch im Feed.

Wahrscheinlich hat das aber mit der Diskussion hier nichts zu tun.

Edit: Mein neu eingetragenes Copyright wird jetzt in Apple Podcastsconnnect angezeigt, aber an der Transkriptsituation hat sich nichts geändert.

Bei der neuesten Folge von Tasty MTG (erschienen heute Nacht) hat Apple korrekt das eigene Transkript erkannt. Mit dem Feed aus Podlove scheint es also zu klappen, es dauert vermutlich nur etwas.
image