Analytics Cronjobs stallen bei 0% in 3.4.1

Bei dem Update auf 3.4.1 haben irgendwie meine Analytics Cronjobs aufgehört zu funktionieren. Sie werden angestossen, aber bleiben dann alle bei 0% hängen:

image

Sachen, die ich schon versucht habe:

  • Alle Cronjobs neu starten (starten, aber stallen sofort wieder)
  • Cache löschen & reparieren
  • Request IDs neu hashen
  • den Wordpress Cronjob verwenden wie auch nen serverseitigen Cronjob (aktuell läuft es serverseitig jede Minute)
  • PHP Log ausgelesen (da habe ich nur einen WordPress-Datenbank-Fehler bezüglich der Geodaten entdeckt, könnte es das sein?

Duplicate entry '2910278' for key 'geoname_id' für Abfrage INSERT INTO podcoaster_podlove_geoarea ( id,geoname_id,parent_id,code,type ) VALUES ( NULL,'2910278','38',NULL,'city' ); von require('wp-blog-header.php'), wp, WP->main, do_action_ref_array('wp'), WP_Hook->do_action, WP_Hook->apply_filters, podlove_handle_media_file_download, do_action('podlove_download_file'), WP_Hook->do_action, WP_Hook->apply_filters, podlove_handle_media_file_tracking, Podlove\Model\DownloadIntent->add_geo_data, Podlove\Model\DownloadIntent->Podlove\Model\{closure}, Podlove\Model\Base->save

Bislang bin ich ratlos. Das Analytics-Dashboard ist aktuell komplett leer:

image

Wer kann helfen? :slight_smile:

Sehr merkwürdig. Du nimmst ja schon den „guten“ Weg und die Checks sind grün.

Hängt nur der „bereinigen“ task? Du kannst den einmal abbrechen und schauen, ob die anderen durchlaufen. Oder hängen alle tasks?

1 Like

Es hängen alle Tasks. Ich habe auch schon versucht, jeden mal eigens für sich zu starten, aber sie hängen instant.

In der Werkzeuge-Übersicht stehen sie dann als „starting…“ drin.

Das Merkwürdige ist auch noch, dass vor dem letzten Update eigentlich alles funktioniert hat. Auch andere Cronjobs laufen zuverlässig durch, nur die von Podlove mögen seitdem nicht mehr. Analytics liefen vorher vollkommen unproblematisch.

Aufgefallen ist mir noch, dass ich den „URL ist nicht korrekt auflösbar“ Fehler in den Tracking-Einstellungen habe. Das SSL-Zertifikat lasse ich mir selbst von Let’s Encrypt machen. Deswegen ist bei mir die SSL-Peer-Überprüfung in den Expert-Settings deaktiviert.

Im error log ist sonst nichts zu sehen bis auf den vereinzelten mit geoname_id von oben? (der ist kein Problem so lange es nicht regelmäßig passiert)

Das sollte keine Auswirkungen auf die jobs haben. Bin etwas ratlos.

Das ist tatsächlich mein einziger Eintrag im php error log. Seit dem 4. April kam da auch nichts neues mehr hinzu.

Meine PHP-Vesion ist 7.2.24-0ubuntu0.18.04.7 - kann es sein, dass da was zu veraltet ist?