Web player auf android lädt nichts

Hi,
ich versuche gerade zu verstehen, warum der web player auf android nicht funktioniert, auf iOS aber schon.
ich bitte um Entschuldigung für meine vollkommene Ahnungslosigkeit, werde mein bestes versuchen, Hinweise zu verstehen.
der betroffene podcast ist hier:


merci und grüsse!
moritz

Kannst du genauer beschreiben, was nicht fuktioniert?

klar: wenn man die seite im browser unter android aufruf und auf play clickt, dann erscheint der ladebalken aber es lädt nicht, kapitel lassen sich nicht anwählen und es kommt kein mucks aus dem Ausgang.
Mehr wüsste ich gerade nicht zu erklären. Was kann ich noch schreiben, das helfen würde, den Fehler (also meinen, vermutlich, oder besser: ziemlich sicher) zu beschreiben?

bitte entschuldigt, wenn ich es nicht genauer beschreiben kann, vielleicht kann mir jemand schon dabei helfen, das Problem zu präzisieren? Ich wüsste schlicht nicht, wo ich nachschauen kann…
Oder hat niemand eine Idee?

Also bei mir läuft es unter Android. Dauert nur ne kleine Sekunde Ladezeit

Habe das kurz getestet. Auf Android beginnt tatsächlich nichts zu laufen. Auf iOS klingt es bereits nach Sekunden. Wieso das passiert, kann ich dir aber leider nicht sagen. Auf dem PC (Win 7) läuft auch alles bestens.

Die Beschreibung “auf Android” hilft uns leider nicht weiter. Da die Plattform so furchtbar fragmentiert ist ist schon eine sehr genaue Beschreibung erforderlich: Gerätetyp, Android-Version, Version des ggf. vorhandenen UI-Systems etc.

leider habe ich selbst kein android zur Verfügung. Ich habe das Problem allerdings mit Manymo reproduzieren können. Ich versuche noch genauere Specs zu bekommen. Was wären den @McCouman s Spezifikationen - und was @Joey s?
Ich glaube ja immer noch, dass es irgendwie mit meinen Einstellungen zu tun hat… Andere Podcasts mit Webplayer (allen voran z.B. Freakshow) funktionieren auf den selben Geräten. :confused: wirklich ratlos.

Bei mir läuft es auch nicht.

Samsung Galaxy S4 Mini
Cyanogemod 11.2
Android 4.4.4
Standard Browser

Mir scheint es am Dateiformat zu liegen. Der Webplayer startet, spielt aber nichts ab.
Wenn ich über die Downloadauswahl die Dateien direkt im Browser öffne, kann ich das mp3 abspielen aber nicht das aac.
Bei anderen Podcasts klappt dies problemlos.

die infos die ich bekommen habe war:
samsung galaxy s 6
android 5.1.1

worauf muss ich denn bei aac files achten? und wenn es beide formate gibt, wie wählt denn der webplayer aus? kann ich z.b. ein dateiformat bevorzugt verwenden lassen für den web player?

Dazu kann ich leider nichts qualifiziertes sagen. Benutzt du Auphonic?

nein, kein auphonic. ich mach alles zuvor mit hindenburg.

Gehe mal bitte auf dem betroffenen Gerät auf http://hpr.dogphilosophy.net/test/ und teste die Formate durch. Ggf. musst du für höhere Kompatibilität schlicht mehr Formate anbieten, z.B. Ogg Vorbis.

Ich habe das mit einem Samsung Galaxy S3 (GT-I9300) mit Android 4.3 getestet. Auf der von @ericteubert angegebenen Testseite konnte ich .weba, .ogg, .wav & .mp3 abspielen.

Hm… erstaunlich. Also ich bin Software Entwickler und bin in die automation, in den Bereich Testing gewechselt und arbeite daher in einer Testabteilung. Wir haben so ziemlich jedes Gerät was auf dem Markt ist vorhanden und mit fast allen Versionen. - Ich hatte es nur gelesen und fix mit einem Galaxy S4 Note (Android 5.x) getestet. - Dort ist aber ne eigenständige developer Version und Zusatztools für Automationen installiert + Frameworks (internes Zeugs das ich benötige um zu hacken). Vielleicht verfälscht das mein Ergebnis! Wir habe die aber auch ohne die Tools da, weil wir aus Gründen keine Emulatoren verwenden dürfen. Wenn Du mir sagen kannst welche Formate und welche devices ich testen soll, kann ich das sicher hin und wieder mal in der Pause machen. Oder wenn es da Bedarf auch auf Seiten von Podlove, sprich: @ericteubert gibt.

ok. weniger ist manchmal mehr.
Tests wie @ericteubert erbeten hatte ergaben: auf besagten geräten funktioniert nur das .opus format nicht.

die “Lösung” war: ich habe das .aac media file der folge deaktiviert und nur noch mp3 übrig gelassen. jetzt “funktioniert” es. Aber eine Lösung ist das nicht, oder?
warum verhindert denn .aac das abspielen einer eigentlich funktionierenden .mp3 über den webplayer? das verstehe ich noch nicht. kann ich aac files irgendwie testen? kann es da fehler geben?

Wie denn nun? :slight_smile:

Grundsätzlich klingt es mir nach kaputtem Browser auf deiner Geschmacksrichtung von Android/Gerät. Wir stellen nach HTML5 Standard ein Audio Element mit mehreren Quellen bereit. Browser nehmen sich den ersten, den sie abspielen können. So zumindest die Theorie / der Standard. Vielleicht meint der Browser auch, er könne aac abspielen, obwohl er es nicht kann. Unklar.

Eine Lösung habe ich nicht parat.

Das aac media file abzustellen ist im übrigen eine ganz schlechte Idee. Denn so verschwindet die Episode aus den Feeds aller, die den aac Feed abonniert haben.

opus funktioniert nicht - verwende ich aber auch nicht. Das kann Hindenburg leider nicht erzeugen.
Vielen Dank für die Hinweise. Das seltsame ist ja, dass andere Podcasts mit Podlove auf selbem Android funktionieren.
Das aac habe ich nur kurz abgestellt, um zu testen.
Ich weiss also nicht mehr weiter. Aber danke für eure Hilfe.
Ich hoffe einfach, das Problem ist nicht so gross, weil die meisten es mobil wohl nicht über den browser, sondern durch irgendwelche podcatcher abholen. Und am PC/Chrome/Mac funktioniert es ja perfekt.

Falls jemandem noch eine geniale Lösung kommt… ich würde auch noch mehr versuchen. :slight_smile:

ok. ich bin mir ziemlich sicher, dass hier ein Problem mit meinen Einstellungen oder dem aac file selbst besteht. Ich habe aber keine Ahnung, wie ich das prüfen kann.
es liegt sicher nicht am browser des gerätes.

meinen m4a feed http://www.1968kritik.de/feed/m4a/ kann selbst ein podcatcher auf android nicht verarbeiten (getestet auf selbem gerät mit podcast addict).

der m4a feed von - völlig zufälliges beispiel :wink: http://logbuch-netzpolitik.de/feed/m4a - geht problemlos. @ericteubert, ich bin mir nicht sicher, ob das hilft zur klärung, aber es fuchst mich, dass ich so aufgeschmissen bin.