Was bedeutet "rtaudio: buffer overflow"

Hallo!

Wir sind quasi jetzt soweit, einen neuen Podcast anzufangen und dachten, wir hätten die Technik in Griff, aber als wir die Nullnummer aufnehmen wollten, sprang sie uns in unerwartet in den Nacken.

Wir haben auf der einen Seite einen etwas älteren Rechner und eine 16mbit-DSL-Leitung. Auf diesem läuft Studio-Link-Standalone in Standard-Einstellungen. Sobald hier etwas mehr gesprochen wird, wird die Übertragung verzerrt und abgehackt und Studio-Link zeigt die Meldung "rtaudio: buffer overflow" an.

Wir wissen nun nicht, welcher Buffer hier überläuft:

  • Kommt der Rechner nicht nach, das Audio-Signal zu komprimieren/umzuwandeln?
  • Oder schafft er es nicht, das Ergebnis durch die relativ enge 16mbit-Leitung zu schieben? Wie groß der Upstream genau ist, konnten wir nicht herausfinden, aber sooo viel ist das ja nicht, eigentlich sollten das auf jeden Fall reichen.
  • Oder bedeutet die Meldung etwas ganz anderes?

Für einen kleinen Tipp wäre ich sehr dankbar!

Viele Grüße
Wolfram

Das bedeuted das der Audiopuffer vom Audiointerface/Treiber überläuft. Das kann mehrere Ursachen haben.

Daher bräuchte ich noch ein paar Eckdaten:

  • Standalone Versionsnummer
  • Betriebssystemversion
  • Audiointerface
  • Samplerate auf 48kHz?
1 Like

Hey, danke für die schnelle Antwort.

  • StudioLink Version: v19.09.0-beta-693.9c01a0d
  • Betriebssystem: Windows 10 Pro (Version 1903)
  • Audiointerface: Edirol UA-4FX und Xenyx 302USB - wir können es mit beiden erzeugen.
  • Samplerate: Kann ich gar nicht sagen, ich weiss nicht, wo ich das bei Studio-Link einstellen kann. Allerdings: Wir brauchen gar nicht zur versuchen, aufzunehmen. Wir bekommen die Meldung sogar, wenn wir mit dem Echo-Test-Account “sprechen”.
1 Like

Behringer Xenyx = stereo zu je 16bit @48kHz

1 Like

Geht nur über das System:

Kannst du mir einmal das gesamte Standalone Log zur Verfügung stellen (gerne als PN).

1 Like

Du kannst auch gerne mal folgende Version testen:

https://download.studio.link/nightly/buffer/v19.09.1-beta-723.75554dd/windows64/studio-link-standalone-v19.09.1.exe

Hier habe ich testweise größere Puffer Einstellungen hinterlegt.

2 Like

Hi!

Nochmal vielen Dank! Wir haben weiter rumgetestet und es scheint so zu sein, dass auf dem alten Rechner die Onboard-Soundkarte und Win10 gar nicht miteinander klarkommen…
Obwohl die sich eigentlich gar nicht einmischen sollte, wenn wir es mit einem der anderen Audio-Interfaces versuchen, sind die Overflows anscheinend weg, wenn wir die Karte im Bios disablen.
Wir haben aber auch festgestellt, dass die Samplerates auf 44100 eingestellt waren - das haben wir natürlich umgestellt.

Da die Probleme im Moment (toi, toi, toi) weg sind, erspare ich uns das Log bis zum nächsten Auftreten :slight_smile:
Dazu aber doch eine Frage: Wenn Studio-Link von Reaper/Ultraschall aufgerufen wird, wird das Dos-Fenster, das mal bei Standalone hat, offenbar unterdrückt - gibt es in diesem Fall eine Möglichkeit, an Logs zu kommen?

Viele Grüße
Wolfram

1 Like