Von Podlove generierter Feed funktioniert nicht

Hallo zusammen,
wir haben gerade einen neuen Podcast gestartet und auf einem neu aufgesetzten Wordpress Podlove installiert.
Da ich das alles schon mal gemacht habe (damals auf einer älteren Version) ist alles recht leicht von der Hand gegangen.
Lediglich der Feed für den Podcast funktioniert nicht.

“Diese Webseite ist nicht verfügbar. ERR_CONTENT_DECODING_FAILED” (beim Anklicken in den “Podcast Feed”- Einstellungen)

“Could not subscribe. unknown format (magic number bbef)” (beim Abonnieren per Subscribe-Button mit PodCatcher auf meinem Android Telefon)

Die Einstellungen sehen für meine Augen ganz gut aus, entsprechen auch denen im alten Podcast, bei dem alles funktinoiert.

Allerdings sieht die generierte Feedstruktur (besonders die Endung) anders aus als beim alten Feed.

Vielen Dank schonmal für eure Hilfe.
Verzweifelte Grüße,
Adrian

Höchstwahrscheinlich eine Inkompatibilität mit einem anderen Plugin.

Schon mehrfach vorgekommen:

Du musst in WordPress noch “pretty permalinks” aktivieren, sonst siehst du die Parameter in der URL. Ist aber rein ästhetisch. Funktioniert auch so.

Hallo Eric,
leider habe ich das mit dem Plugin schon probiert. Es ist nur 1 Plugin nebenher installiert und auch die Deinstallation dessen und Neuerstellung des Feeds hilft nicht weiter.

Hier mal noch ein Auszug aus dem Dashboard:

Oder kann es daran liegen, dass auf einem Webserver (uberspace) mehrere Wordpressinstallationen liegen (in unterschiedlichen Ordnerstrukturen)?
Gruß

Ah, uberspace. Hilft https://wiki.uberspace.de/webserver:htaccess#kompression (via https://community.podlove.org/t/solved-problem-mit-gzip-und-zencache/385/3?u=ericteubert)?

Vielen Dank.
Habe das Problem mit dem Hinweis gelöst gekriegt.
Durch das Einfügen von:
add_filter(‘podlove_enable_gzip_for_feeds’, function() { return false; });
in die wp-settings hat alles geklappt.

Vielen Dank nochmal!
Besten Gruß,
Adrian

Das ist die Notlösung, da du somit Feed-Kompression ausschaltest. Unangenehm für deine Nutzer, da sie für jeden Feed-Refresh mehr Daten laden müssen.

Aber wenn du es so lassen möchtest, pack das Snippet irgendwohin, wo es nicht mit dem nächsten WP-Update überschrieben wird :slight_smile: https://wordpress.org/plugins/code-snippets/ ist eine Variante.