Studio-Link Standalone, nur ein Kanal wird aufgenommen

Hallo zusammen
Mein Studio-Link-Standalone unter Linux funktioniert super und ich bin hell begeistert. Ein Problem habe ich aber: wie kann ich bei einem Telefoninterview beide Kanäle aufnehmen. Bei mir wird immer nur der lokale Kanal aufgenommen.
Danke und Gruss, Ralf

Mit welcher Software nimmst Du auf?
Pulseaudio yes or no?

Ja, Pulseaudio

Und welche Aufnahmesoftware?
Auphonic?
Ardour?

Wie kommt Deine Stimme in den Rechner? Mikro direkt oder über Interface?

Mikro -> Interface -> PulseAudio
SM7B -> Scarlett 2i2 -> PulseAudio

Falls Du einen ZOOM H6 verwendest, im Pulseaudio Playback Tab den “AudioIPC Server” (die Gegenseite) nach “H6 Digital Recorder Analog Stereo” routen und am H6 “Direct Monitoring” aktivieren. Dann hörste euch beide und es werden auch beide vom Studio-Link aufgenommen,
jedenfalls bei mir.

Danke, mailonator, aber meine Probleme mit Studio Link Standalone (SLS) sind viel grundsätzlicherer Natur. Meine Audiokette funktioniert einwandfrei. SLS nimmt mein lokales Signal in einer Flac-Datei auf, aber ich erhalte fünf remote Flacs ohne Inhalt. Vermutlich fehlt mir eine Dokumentation, die die Basisanwendung von SLS erklärt. ‘Enter Partner Id + Call’ funktioniert nicht; um nur ein Beispiel zu nennen. Ich habe das jetzt drei Tage lang ausprobiert und bin langsam frustriert, weil ich keine bessere Anwendung kenne um remote Podcasts aufzunehmen. Jede Hilfe ist gerne willkommen.

Das mit den fünf remote FLACs geht schon in Ordnung, SLS kann max 5 Calls, wenn ich nur einen anrufe sind 4 remote FLACs leer.

Zu ‘Enter Partner Id + Call’: Hast Du rechts oben “Status: OK” und eine lokale ID hinter “Your ID:” ?

Du rufst SLS sicher im Terminal auf, da muß sich in der Ausgabe etwas der Art
Register OK: sip:12345678@studio-link.de finden, wobei 12345678 Deine ID ist.

Was gibt SLS im Terminal als Fehler aus?

Ansonsten kann mit der ID echo@studio-link.de prima testen

Vielleicht helfen noch ein paar Umgebungsinformationen:

  • Betriebssystem: Ubuntu 18.04
  • Audio: Pulseaudio
  • Mic: Shure SM7B
  • Interface: Focusrite Scarlett 2i2
  • Browser: Firefox 67.0.1
  • Studio-Link Standalone: v19.04.0-beta-605.7ebfed8

Nehmen wir das mal als richtig an, zumal SLS ja Dein Signal aufzeichnet.
Ich meine, wir müssen uns auf SLS und die Call-Probleme konzentrieren. Meine Fragen dazu haste.

Ich bekomme keinerlei Fehler im Terminal angezeigt. Nochmal: ich glaube, dass ich nicht verstehe, wie man die Anwendung überhaupt verwendet. Ein Call auf freakshowX zeigt zum Beispiel keinerlei Gain. Aufgenommen wird auch nichts, ausser meinem eigenen Signal. Wenn ich das aus der spärlichen Dokumentation im Internet richtig verstanden habe, ist SLS gar nicht in fähig, ein Remote Signal aufzunehmen. Dieses müsse beim Remote-Partner aufgenommen werden. Und wenn das wirklich stimmt, weiss ich gar nicht wozu SLS überhaupt gut sein soll; dann kann ich auch gleich jeden Co-Podcaster mit Audacity aufnehmen lassen und mische das nachher von Hand zusammen. Du siehst, mir fehlt es am Grundverständnis, was Studio-Link überhaupt sein soll.

Hast Du rechts unter CALL ein established?
Wenn nicht, dann haste keine Verbindung und damit auch keinen Pegel.

Vermutlich weil - ich zitiere Dich - ‘Enter Partner Id + Call’ funktioniert nicht;
Und diesem müssen wir auf die Schliche kommen.

Wenn Du im Terminal das Kommando eingibst, was kommt dann als Ausgabe?

Wenn ich bei ‘Enter Partner ID’ etwas eingebe, z.b. ‘freakshow3@studio-link.de’, und dann CALL klicke, passiert gar nichts.

“Wenn Du im Terminal das Kommando eingibst, was kommt dann als Ausgabe?” Welches Kommando? Ich starte SLS im Browser über die IP: http://127.0.0.1:35139/ bzw. über ein .desktop File.

Oha.
Dann mach mal ein Konsol- bzw. Terminal-Fenster auf. In diesem rufst Du dann das Binary auf. Wie das bei Dir heißt und wo es im Filesystem residiert weiß ich nicht. Ggf. hilft ein find / -name “studio-link*”.

Dann läßt sich auch die Frage nach der Ausgabe des Programms beantworten.

Hinter welchem Router hängt das Ganze?

Vielen Dank für eure Hilfe. In der Zwischenzeit funktioniert alles wie gewünscht. Eine Frage habe ich aber noch: Studio-Link-standalone scheint das Stereo/Mono-Setting zu ignorieren. Vielleicht liegt es aber auch an Audacity, dass mir beim Importieren immer eine Stereo-Spur anzeigt.

Liegt an Studio-Link, passiert bei mir auch.

Das Setting bezieht sich aktuell nur auf das ausgehende Signal. In der nächsten Version wird dieser Teil aber anders gelöst (Auswahl des Audio Kanals in den Audio Einstellungen).

1 „Gefällt mir“