Studio Link debuggen (allgemein und spezifisch)

Hi zusammen,

wie bei uns allen verlagert sich die Produktion der Podcasts ins Home-Office, was u.a. bedeutet Teilnehmer anzubinden, die bisher kein Setup zu Hause haben. Gibt es eine Möglichkeit, ein Studio Link Setup zu debuggen, was trotz korrekt erscheinender Einstellungen einfach nicht funktionieren will? Es ist für alle Beteiligten frustverstärkend, wenn man am Ende einer Kette von Versuchen auch selber nur sagen kann “Ich weiß nicht woran es liegt”.

Konkretes Beispiel: Wir haben gestern eine Aufnahme produziert mit insgesamt 4 Studio Link “Anrufern” und mir als zentralem Studio, bei dem alles zusammenlief. Drei der vier Teilnehmer konnte ich problemlos hereinholen, der vierte war partout nicht zu hören. Wir haben alles mehrfach gecheckt, das Setup der nicht funktionierenden Gegenstelle bestand aus einem Zoom H6 im Interface Modus und der neuesten Studio Link Standalone Version, in deren Webinterface alle Interface Einstellungen richtig gesetzt waren. Im Browser sah man auch einen Pegel, der vom H6 kam. Nur übertragen wurde nichts, ich sah auf der entsprechenden Spur keinen Pegel auf der Gegenseite. Da steht man dann ein wenig ratlos daneben und kann nichts debuggen, weil ich nirgends ein Log habe (zumindest nicht weiß, wo ich das ggf. hätte) oder auch nur einen Ansatz, wo hier ggf. das Problem liegen könnte.

Könnte das eventuell in einem “Advanced View” o.ä. umgesetzt werden? Ich würde gerne nicht mehr blind raten müssen, woran solche Probleme liegen - evtl. gäbe in so einem Fall wie oben beschrieben ja ein Blick in die Logs der SIP Verbindung Aufschluß oder vielleicht kann man einen Verbose Mode für das Studio Link interne Routing irgendwo sichtbar machen? Geht da was?

2 Like

Der einfachste Test ist immer der “echo@studio.link” Account, den sollte in so einen Fall die andere Standalone anrufen um das eigene Setup zu testen. Wenn du schon offene Calls hast, empfiehlt sich das lokal beim Plug-in nicht mehr (Signal schaukelt sich auf). Da wäre es besser z.B. “music@studio.link” anzurufen.

So ist dann besser zuzuordnen auf welcher Seite (lokal oder remote) das Problem nun eigentlich besteht. Du kannst mir gerne mal ein paar beteiligte Studio Link Nummern als PN schicken. Dann schau ich mal ins Log.

1 Like

Um das nochmal, unabhängig von meinem spezifischen Fall, aufzugreifen: Ist es grundsätzlich möglich bzw. geplant, auf der Studio Link Oberfläche mehr Informationen anzuzeigen zu den SIP Verbindungen? Ich würde gerne einfach mehr sehen und ggf. selber auf Problemlösungen kommen als es momentan möglich ist. Zur Zeit ist es mehr ein Ratespiel und ausser vagen Fehlermeldungen kriege ich kein Feedback. Was bedeutet z.B. bei fehlgeschlagenen Verbindungen ein Fehler 404 - ist das ein HTTP Statuscode? Bezieht sich dieser auf den SIP Server oder auf meine Gegenstelle? All das könnte ich schonmal klären, wenn ich irgendwo ein Log hätte, in dem steht “Server gefunden - Server kann keine Verbindung herstellen, hier ist die Fehlermeldung: …”

Ginge sowas? Wie gesagt, gerne hinter einem “Advanced”/“Ich weiß, was ich tue”-Tab.

1 Like

Das sind SIP Status Codes: https://de.wikipedia.org/wiki/SIP-Status-Codes

404 Not Found Die Gegenstelle wurde nicht gefunden oder existiert nicht.

Das bedeuted die gewählte SIP “Rufnummer” ist nicht verfügbar. Auf Studio Link bezogen sind folgende Ursachen denkbar:

  • Client nicht gestartet
  • Netzwerkfehler (Status auf der anderen Seite ist Error)
  • Nummer ist falsch

Ich überlege mir mal etwas, kann aber noch dauern.

2 Like