Podcasts-Seite 2 fehlt

Hallo,

ich hoste den podcast ZellKultur mit podlove via wordpress. Leider lassen sich auf der Website ältere Episoden nicht anzeigen: Sobald man (ganz am Ende der Seite) auf Seite 2 oder “Zurück” geht findet man… nichts:
https://zellmedien.de/podcast/page/2/

Ansonsten alles fein. https://zellmedien.de/podcast/

Ich dachte, es läge eventuell am Theme und habe dieses nun gewechselt. Anscheinend (Quelle: Internet) nutzen viele Twenty Seventeen (mit “ein bisschen CSS” - ohne zu definieren was genau gemacht wurde). Mit dem “neuen” Theme funktioniert es nun aber auch nicht.

Bevor ich daher noch mehr zerstöre: Hat jemand eine Ahnung wo ich suchen kann? Vielleicht hab ich nur einen Halen in den Podlove-Einstellungen übersehen? Ich kann gerade so ein bisschen PHP einfügen und bin ansonsten harmlose Biologin ohne besondere technische Kenntnisse.

Vielen Dank schon Mal
Anna

Hi Anna,

wo/wie hostest du denn das WordPress? Meine erste Vermutung wäre die Webserver-Konfiguration – da ist nämlich u.U. ein wenig Anpassung notwendig, damit das mit den Seiten klappt. Was ist denn unter https://zellmedien.de/wp-admin/options-permalink.php eingestellt?

Hm, da bin ich noch gar nicht drauf gekommen.
Ich mache lieber mal gleichen einen Screenshot. image

Ich habe aber mit dem Ändern der Permalinks eher negative Erfahrungen gemacht…

Kannst du noch den Systembericht von https://zellmedien.de/wp-admin/admin.php?page=podlove_Support_settings_handle hier posten?

Das hier?

Website https://zellmedien.de
PHP Version 5.6.40
WordPress Version 5.2.3
WordPress Theme Twenty Seventeen v2.2
Active Plugins
- Akismet Privacy Policies v1.1.2
- Akismet Anti-Spam v4.1.2
- Woody ad snippets (PHP snippets | Insert PHP) v2.2.7
- Lightweight Social Icons v1.0.1
- Noindex Pages v1.0.1
- Podlove Podcast Publisher v2.9.3
- Podlove Subscribe Button v1.3.7
- Steady für WordPress v1.0.12
- The Events Calendar v4.9.8
- TinyMCE Advanced v5.2.1
- GDPR Cookie Consent Banner v2.3.14
- UpdraftPlus – Sichern/Wiederherstellen v1.16.16
WordPress Database Charset utf8mb4
WordPress Database Collate
Publisher Version 2.9.3
Web Player Version player_v2
Twig Version 1.42.2
open_basedir ok
curl Version 7.38.0
iconv available
simplexml ok
max_execution_time 30
upload_max_filesize 32M
memory_limit 256M
disable_classes
disable_functions mail
permalinks ok (/%category%/%postname%/)
podlove_permalinks ok
podcast_settings ok
web_player ok
podlove_cache on
assets

  • mp3 audio/mpeg http://zellmedien.de/feed/mp3/
  • chapters.txttext/plain no feed
  • jpg image/jpeg no feed
  • ogg audio/ogg no feed
  • opus audio/ogg;codecs=opusno feed
    cron ok
    duplicate_guids ok

0 errors
0 notices
Nice, Everything looks fine!

Genau, Danke. Weißt du, ob dein WordPress mit nginx oder mit Apache gehostet ist? Wer/wie/wo hat das WordPress denn eingerichtet? Prinzipiell scheinen deine Permalinks zu funktionieren, aber aus irgendeinem Grund scheint es bei den Seiten nicht zu klappen. Das kann ein verschiedene Ursachen haben, schwierig zu diagnostizieren ohne die gesamte Konfiguration zu sehen.

Kannst du noch einen Screenshot vom oberen Bereich (Website Einstellungen) unter https://zellmedien.de/wp-admin/admin.php?page=podlove_settings_settings_handle und von den Einstellungen unter https://zellmedien.de/wp-admin/options-reading.php machen?

Das Wordpress hab ich damals selbst aufgesetzt, schon 5-6 Jahre her als da nur das Blog lief. Ich überlege ob es damit zu tun haben könnte, da die Installation etwas verkorkst ist - ich habe 2 wordpresses am laufen (ursprünglich wollte ich direkt 2 seiten aufsetzen), aber nur 1 nutze ich. Beim versuch das andere zu löschen hab ich aber wenig Erfolg gehabt. Danach war alles kaputt und ich habe ein Backup wiederhergestellt.1 2

Achso, und Apache müsste es sein.

Ah, das ist interessant. Probier mal, was passiert, wenn du unter “Episoden Seiten” bei https://zellmedien.de/wp-admin/admin.php?page=podlove_settings_settings_handle “podcast” einträgst statt “ZellKultur”.

Hat leider nichts gebracht. Seite 2 funktioniert nicht. :frowning:
(auch noch mal in einem anderen Browser im privaten Modus geöffnet)

Schade :confused:

Das Stichwort sind sogenannte “Rewrite Rules” – das sind Regeln, anhand derer der Webserver die aufgerufene URL interpretiert und in eine andere URL umschreibt. WordPress erwartet nämlich die Seitenangabe eigentlich in diesem Format in der URL: ?page=2 – damit das schöner lesbare /page/2 funktioniert, müssen die Rewrite Rules funktionieren. Genauso ist es auch mit den Episoden – eigentlich würde WordPress sowas wie index.php?p=123 erwarten, aber durch die Rewrite Rules ist der Beitrag mit der ID 123 unter z.B. /post/mein-beitrag erreichbar.

Da deine Podcast-Episoden “saubere” URLs haben, kann das URL Rewriting nicht komplett deaktiviert sein. Aber die Seiten funktionieren nicht, darum ist es vermutlich nicht ganz im Reinen. Du kannst mal versuchen, dir das “Debug This”-Plugin zu installieren: https://wordpress.org/plugins/debug-this/

Damit kannst du sehen, welche Rewrite Rules greifen, das sollte auch bei der nicht funktionierenden URL zur Seite 2 klappen – eventuell gibt das weitere Hinweise darauf, was da genau abläuft.

(Nach der Installation einfach die Seite 2 aufrufen und dann oben in der WP Menüleiste bei Debug This unter “Query” den Punkt “Rewrites” – da am Besten auch mal einen Screenshot machen.)

Da das ne recht lange liste ist, habe ich mal ein PDF gemachtDebug This.pdf (4,7 MB)

Kann es sein, dass du vorhin nicht “podcast”, sondern “Podcast” in das Feld eingetragen hast, wo vorher “ZellKultur” drinstand? So lese ich es zumindest aus den Rewrite Rules heraus, und tatsächlich funktioniert die Seite 2 auch, wenn ich es in der URL auch großschreibe. :slight_smile:

https://zellmedien.de/Podcast/page/2/ funktioniert
https://zellmedien.de/podcast/page/2/ funktioniert nicht

Huch, ja, jetzt funktioniert es! Habe jetzt das kleine p eingetragen. :flushed:

Vielen lieben Dank! Hab wieder was gelernt! :smiley:

Super, das freut mich – und gelernt haben wir beide was. :smile:

1 Like