Phone sound - firewall

Hi Sebastian (and others),

First of all: compliments on studio-link. This has been by far the best solution for recording podcasts remotely since Covid19 came round the corner.

I mainly record at corporate clients and now most of them need to work from home. Since one can use studio-link with a native smartphone app and just use the phone as you would do during a call this is an ideal solution for me to get the best audio possible.

Yesterday I made a test call with a friend. Awesome quality. But today, just before an important press conference from our government I only had phone line quality. The client was unable to use the internal network due to restrictions.

So a few questions come up:

  • is the lower quality a result of using a 4G cellular connection?
  • what data ports and sorts need to be open to use studio link with Softphone installed on a smartphone.
  • can I force better quality from my end in a way?

I’m using the plug-in together with UltraSchall on a Mac with Mojave.

Apologies for English as I’m just very bad at writing in German, but please do answer in German if you want as I can understand that quite well as a Dutch guy.

Thanks! Joey

1 Like

The reduced quality from softphone came from the “echo cancellation”:

https://doku.studio-link.de/mystudiolink/cloud-softphone.html#optionen-audioeinstellungen-unter-ios

This is activated by default, just deactivate as described when headphones are connected.

Unfortunately, most devices will generate an echo without these settings, otherwise I would prefer to set the settings to “Off” by default.

Unfortunately no, I have 2 manuals written what a client should do after installing the app. One of the things in that manual is to set the settings as described in your link.

It is not the ‘Skype’ kind of sound I’m referring to. I’m talking about landline quality. So nothing above 4K in the audio.

Do you want me to send a part of the audio so you can listen for yourself?

Still keeps the question about ports open.

Joey

You are right, there was a bug introduced by an app update, I just rechecked and fixed the 3G Options, the quality should be much better now.

Firewall Ports:

STUN/TURN: 3478 UDP/TCP
SIPS/HTTPS: 443/5061 TCP (TLS)
DNS: 53/UDP/TCP

1 Like