<MORE>-Tag funktioniert nicht / Beitragsvorschau in WordPress

Hallo.

Ich bin fast sicher, dass es sich um ein templatespezifisches Problem handelt, aber ich versuche es trotzdem mal.
Auf unserer (sonst wunderschönen) Podcastwebsite
https://labroad.de/
werden auf der Startseite alle Beiträge in voller Länge, aber ohne Formatierung angezeigt. Das ist unschön und ich finde ums VERRECKEN keinen Grund dafür.

Was ich möchte: Einen kurzen Teaser-Text, der automatisch irgendwann abgeschnitten wird, und den ich zusätzlich, so wie es ja auch gedacht ist, auch an beliebiger Stelle mit dem <!--more--> Tag abtrennen kann.
Besagter Tag wird völlig ignoriert, im WP Customizer ist die entsprechende Option eigentlich auch aktiviert.

Bildschirmfoto 2020-07-06 um 20.48.24

Falls irgendwer einen Lösungsweg weiß, würde ich mich sehr freuen.

Wenn Du das Tag in einem Podlove-Template nutzt, wird es tatsächlich ignoriert. Du könntest das vermutlich so lösen: 1. Erstelle ein Podlove-Template, das nur die Summary der Episode ausgibt. 2. Füge es als erstes oben in den HTML-Teil der Episode ein. 3.
darauf folgt das More-Tag von Wordpress und danach der restliche Kram mit Formatierung und Links.

In den Podlove-Einstellungen kannst Du ggf das HTML zum Feed hinzufügen. Damit sollten diese Inhalte auch im Feed auftauchen, aber im Blog sollte sich nichts ändern. Außer, dass auf der Startseite nur das steht, was Du dort sehen möchtest.

1 Like