Email an Mitwirkende - email Benachrichtigung


#1

Hallo!
Ich versuche nun schon seit geraumer Zeit die automatische email an die Mitwirkenden zum Laufen zu bringen. Im Debug Log sehe ich stets den selben Fehler, der aber wenig aufschlussreich ist - zumindest für mich :wink:
Vielleicht kann ja jemand von euch helfen!

Fehler im Debug Log:

Tried sending email notification to Univ. - Prof. Dr. Markus Arndt. wp_mail was unable to send. Details ein-/ausblenden

module: E-Mail Notifications
contributor_id: "2"
contributor_name: ‘Name vom Gast’

Mehr steht leider nicht.
Danke!
Andreas


#2

wp-mail hat ja erst mal nichts mit dem publisher zu tun. Kann deine wordpress Installation denn generell Mails versenden? Teste es zB mal mit der Password vergessen Funktion…
LG
Jens


#3

Hi, sorry, ja klar. hab ich getestet. Update notifier und andere email dienste arbeiten wie sie sollen…hab ich vergessen dazuzuschreiben :wink:


#4

Das erinnert mich an dieses Problem. Das sollte aber mittlerweile gefixt sein.

Vielleicht helfen dir die dort genannten, bei mir seinerzeit erfolglosen Schritte.


#5

Hatte deinen Beitrag schon gefunden. Der hat mir leider nicht wirklich weitergeholfen. Denn andere WP-emails werden ohne weiteres gesendet…:face_with_raised_eyebrow:


#6

…was mir aber aufgefallen ist. Ich habe auch die Testfunktion genutzt um die email an mich zu testen…und wenn ich das mache, dann steht im log aber dennoch der Contributor der Folge, welche ich für den Test ausgewählt habe…sollte da dann nicht meine “test email adresse” stehen?

Und im log steht auch immer nur der name mit ‘…’ - sollte da die email stehen? Oder wirklich nur der name? Was steht da bei euch?

…und wem mein “curl error” ins Auge sticht…ich kann bei meinem provider (shared hosting) das open_basedir nihct ändern…gibt es da eine andere Möglichkeit das los zu werden (ok, das wäre nun aber ein eigener Beitrag :upside_down_face:)


#7

…die emails oben im Bild waren alles test emails und sehen all gleich aus…


#8

Bei mir gingen die WordPress Mails auch.

Was, wenn Du die Testmail super simpel schreibst? Inhalt: Test 123. Geht die auch nicht raus?

Auf welcher Podlove-Version bist Du?

Vielleicht ist da was noch nicht ganz gefixt, @ericteubert?


#9

Hallo!
Danke für die Tipps - hat leider nichts genutzt…

Außerdem sieht das Log so aus, als ob er die Testemail an meinen Gast schicken wollte - oder täuscht das?
Hatte dazu meine private emailadresse eingegeben…

Noch jemand eine Idee?


#10

“Versende E-Mails mit Name und E-Mail des angegebenen Mitwirkenden” – und dieser Absender darf per wp_mail bei deinem Provider Mails einreichen?

Die anderen Dienste, die du angesprochen hast, versenden ja vermutlich mit dem klassichen “wordpress@(DEINEDOMAIN)” als Absender.


#11

Hallo! Danke…ich denke du könntest genau ins Schwarze getroffen haben!

Das hab ich noch gar nicht geprüft - und um ehrlich zu sein, war mir das immer schon ein Rätsel, warum Wordpress überhaupt emails versenden kann - hab ich doch noch nie meine SMTP Server Zugangsdaten irgendwo in meiner Worpress Installation eingegeben. Aber das hat der Provider wohl (beides liegt am selben Server) intern direkt erledigt - zumindest für die wordpress@… Ich hab ein Plugin am laufen, ich denke es heißt update notifier und dem hab ich einen eigenen Absender eingetragen - einen den es am smtp gar nicht gibt und das geht trotzdem, was mich auch immer schon gewundert hat :wink:

Kann ich dazu selber irgenwo etwas prüfen? Oder kann das in dem Fall nur der Provider?

Danke! Eine heiße Spur…:wink:


#12

Meist sind die so eingestellt, dass der Server selbst alle Absender “seiner Domain” versenden darf. Daher auch “wordpress”, selbst, wenn es den account gar nic ht gibt. Also solange der Absender xyz@(Deinedomain) ist, sollte es gehen.

Wenn er nun aber versuchen soll z.B. Macmueller@web.de als Absender zu nehmen, dann macht wp_mail das, aber der Mailserver blockiert dann das versenden.

In der Regel hilft die Hilfe des Providers oder trial and error. Ich würde aber immer dazu raten, ein SMTP Plugin einzusetzen, das wp_mail ausschaltet und ALLES über einen definierten, existierenden Account versendet.


#13

Danke, wusste nicht, dass es solche Plugins gibt - werd das mal testen! Mal sehen ob das hilft!


#14

Ach sch… - smtp plugin installiert! Funktioniert super! Nur die Contributors wollen immer noch nicht gesendet werden… :face_with_symbols_over_mouth:

Noch jemand eine andere idee wo es hier hackt?

…was mir noch aufgefallen ist. Im log steht immer noch das selbe “wp_mail konnte nicht…” Das plugin, welches ich verwende hat den wp_mailer aber deaktiviert, was ich bei meinem update-notifier auch bemerkt hab. Der hat auch andere settings gebraucht - geht jetzt aber wieder wie er soll… Nur eben die contributors nicht.

Seitens den wp_mail Einstellungen sollte nun aber alles passen…


#15

Und die Adresse, die beim Contributer “Andreas Strobel” hinterlegt ist, hat die gleiche Domain? (Du kannst auch per SMTP nicht einfach Mails mit “falschem” Absender versenden.)


#16

ja, ist die selbe domain!

…hab zwar mehrere email adressen (und auch mehrere domains) am Start, aber das ist meinem smtp server egal, solange ich mich mit einem gültigen user anmelde und mit einer email verschicken will die es auf meinem server auch gibt…habs mehrfach getestet - in meinem mailclient, mit dem smtp-plugin…klappt immer. nur podlove will keine email schicken.

lässt sich nicht irgendwie genauer rausfinden, warum das senden nicht klappt? das podlove log ist in dem fall eher wortkarg :smirk:

ach ja, hab den Betreff-Text auch schon seit längerem vereinfacht auf reinen Text…das war schon bei den letzten 20 Versuchen so, hatte ich vergessen zu erwähnen.

Danke!